A space to discuss FME Flow
Recently active
Can someone expound on this topic a bit, why would someone use Schedules and create Notifications in Schedules when it can be done a whole lot easier in Automations? Example, setting up an email notification in an Automation is just a matter of adding the Trigger --- Workflow --- Email (one for Success and one for Failure if you like). As opposed to going through the brain twisting effort of using Notifications (Classic) to do this. Automations are so much easier to work with. Does Safe have plans to remove Schedules and Notifications (Classic) in future releases? keep only Automations and improving upon them?
Hi,also see item Error when attempting to turn automation off - Have to run jobs via automation | Community (safe.com).We also encounter this issue after fresh install of FME Flow 2023.2.1 on a new Windows 2022 server. Below are all answers on questions asked in the related topic. Can anyone suggest some path to solutions?: What version and build of FME Flow are you using?FME Flow 2023.1.1 Build 23774 Win64Is this an express, distributed, or fault-tolerant deployment of FME Flow? Distributed (database on a separate MS-SQL Server)If you restart FME Flow, does it resolve (even if temporary)?We restarted FME Flow and that resolved it once. Later we ran into the same issue and after another restart it did not resolve.what is the FME Flow database? The default Postgres, or another, like SQL Server? This is a MSSQL 2019 Database Connect string: DB_JDBC_URL=jdbc:sqlserver://guo10794.k-domstad.org;port=1433;databaseName=fmeserver;TrustServerCertificate=trueThe connect string uses jdbc driver.
Bring the “Deployment Status” back!I really miss the overview of the distributed environment. Which core host is active? Are both of them alive?Let’s not look back, i’m not grumpy, but let’s still find ways to display this info. Whats the reason to depricate the Deployment status?
I'm have created a storage class and persistent volume according to their documentation (https://docs.safe.com/fme/html/FME-Flow/AdminGuide/Kubernetes/Kubernetes-Deploying-to-Amazon-EKS.htm) This is my helm install command: helm install fmeserver safesoftware/fmeserver-2023-0 --set fmeserver.image.tag=21821-20220728 --set deployment.ingress.general.ingressClassName=alb --set storage.fmeserver.class=efs-sc --set deployment.deployPostgresql=false --set storage.fmeserver.accessMode=ReadWriteMany --set fmeserver.database.host=mycluster.rds.amazonaws.com --set fmeserver.database.adminUser=user --set fmeserver.database.adminPasswordSecret=fmeserversecret --set fmeserver.database.adminPasswordSecretKey=password --set fmeserver.database.user=user --set fmeserver.database.name=fmeserver --set fmeserver.database.password=password --set fmeserver.database.adminDatabase=postgres --set deployment.startAsRoot=true -n gis-fmeserver Now my core pod is failing with the following details:All the oth
I upgraded my Development machine Thursday, and install ran smooth, import of backup ran smooth. Checked settings and all appear to match up with Staging and Production, but unable to get Single-Sign-On to function again. Negotiation reported an error: "Failure unspecified at GSS-API level (Mechanism level: Encryption type RC4 with HMAC is not supported/enabled)". All three of my systems use the same Service-Account, and Staging and Prod have not issue, and Dev worked fine until the upgrade.
Hi Folks - I would like to use the FME Server API to get a list of the Web Connections that a workspace uses. I see that there is an endpoint for GET /repositories/< repository >/items/< item >/parameters , but this doesn't provide details regarding the Web Connections configured for the workspace. I currently have a query like:http://domain.com/fmerest/v3/repositories/repo_name/items/workspace_name.fmw/parameters ... and wondering how to change this to get the Web Connection details as well. In the implementation notes of the endpoint above I see the info below, but I am not sure how to use the create a query using the "Sub-type: Web Connection Parameter" Sub-type: Web Connection Parameterparameter {connectionTypes (array[string]): Connection types of this published parameter,defaultValue (string): Default value of the published parameter,description (string): A human-readable description of the published parameter,excludeConnectionTypes (array[string]): Co
I added a new row of info in Attribute Manager in the workspace. This row needs to be added in the Service request on Cityworks. Would republishing the workspace with same name brings in those changes in the Service Request, provided the source will include the new row ? Any insights are highly appreciated.
When enabling feature caching, there is a 'considerable' lag when trying to interrogate the cached features from an output port: usually have to wait 10 -15 seconds to expand the table attribute fields or sort the attribute fields, for instance. When clicking elsewhere to do another activity and returning to the cached features output, the same lag time is experienced. I though the idea was that cached features would be stored virtually, so they wouldn't have to be re-loaded each time? The lag is even present when only interrogating a handful of features. Are there settings that can optimise this to reduce the lag/remove? I do use a VPN to access the workspaces from OneDrive (there workspaces are not stored locally). Version: 2022.2.3.0 (20230131 - Build 22789 - WIN64)
Patching our backend oracle database should the FME server be stopped while the update occurs?
Hi all,What is the correct process to delete admins from FME Server. I deleted 3 fmeadmin users, testing before that any schedules or automations would be assigned to another user etc. Today many of our schedules who are owned by a completely different user are not working. They also don't work if I do a manual trigger. Recreating the schedule does work. Re-adding the user doesn't. I see in the Completed jobs that the schedules that ran before I deleted user have a reference to a Deleted user. I think the only way to fix this is to manually try to trigger each of our 25 job and recreate the schedule on acceptance and production. Any other ideas would be appreciated. And it would be interesting to know what is the correct procedure? Did I miss something? We are using Server 2021 but this server has been upgraded with an old backup since approx 2015 version.
I have a workbench that reads/writes CSV files to a network location. It works fine from my desktop but when published to FME Flow i get permission errors reading and writing. What user is FME Flow using to read/write to the network? any other workaround
FME Form 2023.2 installed produce always a memory Error at startup : "The instruction at 0x00007FFC9A16C1D0 referenced memory at 0xFFFFFFFFFFFFFFFF. The memory could not be read."Click OK to terminate the program. The environnement is VMWARE Windows Server 2019 Datacenter, 16GB RAM, 4 CPU. This same machine runs FME 2020.1 32bits and 64bits with no issues.I have désinstalled ,reboot, reinstalled the FME product , same issue. If this is a know issue , is there a configuration to change ? How to troubleshoot ? Thanks
When creating an automation, I find that the "Next Action" boxes will just clutter the workspace and I end up deleting them anyway. Is there any way that anyone is aware of, that they can be hidden by default? Typically, I setup data downloads to refresh data from various other agencies. So I have a single Trigger, which then executes / queues, multiple workspaces. They can definitely be useful if creating smaller workspaces, so this is where a toggle button would be useful!
Perhaps just of curiosity, I would like to know what all the lines in the safe.lic license file actually mean. Not an answer like "they are needed" but more information why they are needed and what they correspond to. FEATURE FME (this might be the main license)FEATURE FME_GUIFEATURE nationalFEATURE basic_rasterFEATURE segy_readingFEATURE segy_writingFEATURE smallworld (this is the license level)FEATURE fmeobjects_reprojectFEATURE ssis_extensionFEATURE spatialbiz I've heard during my years as a FME expert that some of these lines correspond to "old licensing levels" or similar but now with FME Form, is that really true?
Hi, I recently switched FME Flow Desktop to a new machine and missed exporting my web connections. Is there a way to download them from FME Hosted?
When creating an Automation, I usually use a Trigger to schedule my jobs. (FME Flow Schedule)But is it possible to create an APP whereby the user gets to choose the Date / Time to run it instead of an instant submission of the job? (User Param maybe)
On the documentation website for FME Form, there is a section called "Installing FME Form from the Windows Command Prompt". However, I cannot find any documentation for uninstalling FME Form from the command prompt. Is there any way to do this, so that we can package the uninstall + install for updated processes? Thanks a lot.
I am trying to install FME Flow 20.23.1 on a local MS Windows 2022 Server. I am using / trying to use the silent installer. The command that runs successfully is shown below. The install.logs shows no errors and end with message: "Installation completed successfully" I have an external Tomcat instance btw. I can successfully start the FME Server by using the bat file startCore.bat. After I use this bat file, I can go to http://localhost:8080/fmeserver/ and I can login with admin / admin. Everything looks fine. When I try to start FME Server using the MS Window service created by the installer, it fails with message Error 126: The specified module could not be found I think the service fails fairly quickly in the sense that no real FME processes are started and there is nothing in the log files. It this is a known issue with running FME Flow on MS Windows 2022 server? I checked the documentation but there doesn't seem to be specific requirements mentioned for running FM
If a user follows a direct link to a workspace app or an app gallery, and there is authentication required, a login screen appears. If using 'normal' login with username / password, after login the user gets redirected to the URL in the workspace link., which is correct. However, if I use a Microsoft Azure AD login ('log in with microsoft'), the user always gets redirected to de base URL of FME server and not to the app. Is there somewhere a setting we should set to redirect to the url of the app instead of the base url ?
Is this a bug in FME Flow 2023.1 Build 23619 - win64?
I've followed the steps in this Article to connect my servey to my FME Servey. but I am getting following Error while I'm submitting a new Survey123 to test if it works or not and it looks like that there is no JSON file is created in View Log File Survey submitted successfully, but an error occurred while triggering webhook. http://mvpap###/fme###/v332/automation/workflows/#######-####-41b6-#####-c4073#####/10c98c70-#####-1d82-8a29-######/messageFailed to fetch Can you please help me to solve it?thanks in advance
How to provide/use gRPC flow with FMEflow?
hello everyone I want to produce a point from this data in text format and the XY values I need are in a single stub. The FME dataset area is common for x and Y. I will bring these XY values side by side and produce a point from the vertex creator, but I did not know how to do this.
Hello there, I looked into FME system parameters and Python APIs to find a programmable way to identify release info, such as 2023.2.1, etc., in an FME Form session, to no avail. I would appreciate you sharing your approaches. Bo
Hi everyone, I am currently trying to use the NeighborFinder transformer in Group-By mode to match features from SDE A on features from SDE B. I'm using Group-By to only match objects of the same type (trees with trees, bollards with bollards, etc) and with the same vertical datum class (ground-level with ground-level, below-ground-level with below-ground-level, etc.). However, some feature classes in SDE A do not have a vertical datum class attribute. Using the NeighborFinder in Group-By mode, none of my objects match, since SDE A has <Missing> vertical datum classes, and SDE B has correctly filled in ones.For these feature classes it is alright for the NeighborFinder to only use the obect type attribute. I want to avoid using multiple NeighborFinders in my workspace. I have tried constructing a special Group-By attribute, concatenating the two attributes. But I can't seem to find a nice way for SDE B to not include the vertical datum class when the SDE A featureclass