A space to discuss FME Flow
Recently active
Is FME Server 2021.2.0.1 (Build 21789 - win64) compatible with Tomcat 9.0.72? Thanks.
Hello all, Because of this Microsoft notice on e.o.l. for .NET Framework 4.5/6/7 I got questioned of the dependencies of FME Server. A quick search both on the Safe documentation, as on the interweb did not yield a satisfying answer, so I post it here... On which Microsoft .NET components and versions thereof does FME Server depend? Will upgrading to .NET Framework 4.8 break an FME installation? Client asks for an official statement from us, or from Safe Software that upgrading the .NET framework won't cause any issues. [edit]: It involves both FME Server version 2021.1.1 and 2018.1 Kind regards, Martin p.s. I checked the Windows-FME-servers I have access to, and they all have .NET framework 4.8 installed, so I do have my gut-feelings on this subject. Also I would be more than astonished to hear Safe developing newer releases of their product using outdated Microsoft frameworks.Only those things won't convince the client involved.
I would like my automation to watch a directory. If there's a update, then the rest of the automation runs, but only during the night.I could use a directory watch trigger to run the automation immediately after a change, or use the schedule-trigger to run the automation during the night, but how can I combine those triggers?Thanks, Vera
I am in the process to change FME server from http to https per our cyber security requirements. I am relatively new to the ssl certification installation for web applications. I followed this article to install SSL certificate for FME server. https://community.safe.com/s/article/Using-a-CA-Certificate-with-FME-Server, I obtained a cer file successfully after submitting the CSR string to my company's CA authority. But this command fails to import the certificate for FME server: keytool -import -alias tomcat -keystore tomcat.keystore -trustcacerts -file D:\\FME\\certs\\hou0etgis16\\certnew_base64encoded.cerkeytool error: java.lang.Exception: Failed to establish chain from reply. I tried installing or not installing the root and intermediate certificates using the same cer file, but still the same error for the above command. Any idea? Allen
When importing the certificate i get this error? Has anyone had this happen and what was their resolution?
Dear Community, I have set up a similar Workbench to this tutorial:https://community.safe.com/s/article/extracting-data-within-a-clipping-polygon Except I am fanning out a JSON files for each feature_type. This seems to work in FME Desktop, however when uploaded to the Server I get the following error when using Data Streaming: 1762023-3-25 15:54:00 | Cannot define schema for 'EXAMPLE_DATA' as the feature does not contain schema information, and schema source is set to 'Schema from Schema Feature'. Please verify writer feature type configuration1772023-3-25 15:54:00 | FME API version of module 'JSON' matches current internal version (3.8 20210302)1782023-3-25 15:54:00 | Writer `JSON_1' of type `JSON' using group definition keyword `JSON_1_DEF'1792023-3-25 15:54:00 | FME API version of module 'JSON' matches current internal version (3.8 20210302)1802023-3-25 15:54:00 | Opening the JSON writer with destination dataset 'D:\ProgramData\Safe Software\FME Server\resources\system\temp\enginer
IF I WANT TO FIND RELATED INFORMATION FOR A VERY SMALL AREA MAYBE A 1 MILE SQUARE AOI BUT I HAVE N SDE DATABASE WITH PROBABLY 14 MILLION RECORDS IN IT. THERE IS NO ATTRIBUTE INFORMATION THAT WOULD ALLOW ME TO PREQUERY THE DATABASE RECORDS THAT WOULD BE RELATED.ALSO THERE COULD BE 4 OR 200 RELATED RECORDS. I HAVE TRIED A LOT OF DIFFERENT METHODS. BUT CANNOT FIND A WAY OTHER THAN READING ALL 14 MILL RECORDS. AND IF I HAVE 2 SMALL AOIs THEN I HAVE TO WAIT ALL OVER AGAIN. THE SOURCE OF THE AOI IS USSUALLY KMZ LINE PLACEMARK. ANY HELP OR IDEAS WOULD BE APPRECITATED.
If there any way to configure Server Apps to have require authentication by default? Would it be possible that only an Administrator have permission to turn off authentication on a Server App?
I tried to install a python package in cmd, windows 10, but got error "This workspace requires a Python 2.7 interpreter". How do I make it use python 3.* instead? The same command worked for my colleague so something is wrong in my program setup. I have python 3 installed also. C:\\Program Files\\FME 2022.2.2>fme.exe python -m pip install cron-descriptor --target C:\\Users\\as302\\Documents\\FME\\Plugins\\PythonERROR : This workspace requires a Python 2.7 interpreter, but FME has removed Python 2.7 support starting with FME 2022.0. Please open the workspace in Workbench to change `Navigator > Workspace Parameters > Scripting > Python Compatibility' and update the Python code to be Python 3.x compatible Failed to create Python interpreter for Python version keyword '%0'Program Terminating Translation FAILED.
Hello all,I have an ArcGIS Portal Hosted Feature Layer that has a number of sublayers. One of the layers contains photo attachments. I've had success when the attachments are not in a sublayer using this video as a reference: FME World Tour 2022 How Do You Get 30K Photo Attachments Out of ArcGIS Enterprise or ArcGIS Online? - YouTube However, I'm stuck trying to figure out how to download the photos given they are in a sublayer. The Esri ArcGIS Portal Feature Service doesn't seem to offer the option of sublayer access. Thanks
I've never seen these key outputs when selecting my action to filter messages. Previously, my FME automation was set to filter through my file / directory parent folder to find the correct file needed (when triggered) and then run the respective workspace. Would "Workspace Name" be the correct choice to use here?
Hi,My workspace is reading data from excel and uploading it to gis database. Data streaming is used to be able to return an html to the user. My implementation works if it's run natively from the fme application, but when it's uploaded to the server it will start a duplicate of the same job after 5 minutes. Both of these jobs will then run from start to finish, meaning that duplicates will be created.It seems that this happens only when the excel file has atleast 330 rows. I have also checked that engine does not crash.
Sorry this is going to be a bit of a jumbled question: Recently we started having some issues on our FME Server - When accessing the URL "https://<hostname>.<domain>/fmeserver" would return an error 404. I found some information online involving the WAR folders found under: <ServerInstallDirectory>\\Utilities\\tomcat\\webapps\\ I followed the steps and regenerated the folders. Now when I access the URL: "https://<hostname>.<domain>/fmeserver" is works correctly! However... Now with the newly created WAR folders if I access the URL: "https://<hostname>.<domain>" (note: specifically excluding the /fmeserver) I get an error 404 not found. Previously we never had an issue with this. We have had some security policies updated recently by the security team, and I believe this could be the cause but I'm not 100% certain. If anyone has any ideas as to what would be causing this issue I'd love to hear it. Thanks!
Hi all.I have two sets of automations, where all automations in set 1 needs to be all done before initaiting all automations in set 2.I'm wondering what the best practice is for this scenario ?I tried to include an active wait mechanism in the set 2 automations, but then they just got started first, blocking the set 1 automations.I'm starting all set 1 automations with a single (topic) trigger, as they may run in parallel, and I can start all set 2 automations with another single trigger. But all set 2 need to wait for all set 1 to finish, and that I can't do with triggers as far as I know.All help and suggestions are appreciated.Cheers
I'm wondering to what degree items uploaded to FME Hub are checked? Are they considered "safe to download" or "use at your own risk"? Imagine a wild scenario where I would upload a custom transformer with a SystemCaller in it that formats the c drive, will that get flagged or not? (and what if I password-protect it?)
Hi, Where can I download License Generator that I need to use for my LicenseChecker?
Hello all, When will FME (server and desktop) be supported on the new Ubuntu LTS release 22.04? Thanks for your interest, Martin
Hi, I have been running the JobHistoryStatisticsGathering.fmw using a FME schedule, and in recent times I have been noticing an error (log attached) that I am unable to get to the bottom of.53 2023-3-23 10:00:27 | JobHistoryReader_HTTPCaller (HTTPFactory): [1]: HTTP transfer summary (PANDORA): status code: 401, download size: 52 bytes, DNS lookup time: 3 ms, total transfer time: 97 ms54 2023-3-23 10:00:27 | JobHistoryReader_HTTPCaller (HTTPFactory): An error occurred while accessing the URL 'https://PANDORA:443/fmerest/v3/transformations/jobs/completed?limit=1000&offset=0'55 2023-3-23 10:00:27 | The below feature caused the translation to be terminated56 2023-3-23 10:00:27 | Storing feature(s) to FME feature store file `C:\ProgramData\Safe Software\FME Server\resources\logs\engine\current\jobs\47000\job_47701_log.ffs'...........69 2023-3-23 10:00:27 | Attribute(string: UTF-8) : `_response_body' has value `{"message":"Authentication failed: Failed to login"}'I dont believe I have m
I have a workspace that proceses a lot of features and then writes it to a geopackage but it replaces the file with new data.I want if the file exists to append the features if it does not exists to create the file.How do i do that?
Hello,We install a second server FME to update the version. When this version will be ok, we will stop the old server. All is ok if we run the new server manually but it doesn't work when we want to run fmeserver like a service. 5 services is ok but the fmeserver-database.service doesnt work. Have you an idea? Thanks
A question coming from an organisation with many machines installed with FME servers (40+). Next to the installation we also require a lot of time in configuration for the FME server deployments. We would like to automate deployment and configuration in the near future. We have found Ansible and Chef and also Kubernetes. With kubernetes we have succesfully deployed FME server on premise. The only major issue is the esri dependency of Arcpy scripts and SDE databases. Therefore we are looking for Ansible as a serious candidate for automation. We would like to automate as much as possible, not only because it saves times, but also to make sure all the machines are perfectly similarily deployed. Any tips or recommendations from other users/Safe software? Thanks in advance.
Last saturday (23:46) I recieved the first message above. Then, at Sunday (00:01) I received the second one. Should I be worried about that? (So far, I have not received that kind of message again.)
I have a workbench intended to run daily on FME Server. It does the usual data transformation stuff and then it email reports to a member of staff once per week. The report contains information relating to contractor performance over a 30 day period. I only want to send out a report if there's in new activity in the past 30 days. Currently, I have 9 x reports (one for each contractor). The reports are updated daily. I want the Emailer transformer to email only those reports containing new activity. I have gotten as far as calculating which reports are valid (i.e. within 30days) and using an Attribute Creator to fanout a new attribute, being the path & filename of the report. The Emailer then reads the fanout parameter as the Source File, picks it up and sends it. The problem is, the Emailer is sending each attachment in individual emails. I want the transformer to recognise which reports are valid and then send them together in a single email. The image I have attached shows 5
Hi! We're using FME Server 2021.1.3 Build 21631 - win64. Since last update have problems with access to libraries. Some of jobs crashes on random way. For example:"Module 'VectorToRasterFactory' is unavailable for use with this FME edition"" Library 'C:\\Program Files\\FMEServer\\Server\\fme\\plugins/VectorToRasterFactory.dll' was found but could not be loaded. Ensure that all the dependent modules exist for this library"or"Module 'DatabaseUpdaterFactory' is unavailable for use with this FME editio""Library 'C:\\Program Files\\FMEServer\\Server\\fme\\plugins/DatabaseUpdaterFactory.dll' was found but could not be loaded. Ensure that all the dependent modules exist for this library"or"Module 'TextEncoderFactory' is unavailable for use with this FME edition""Library 'C:\\Program Files\\FMEServer\\Server\\fme\\plugins/TextEncoderFactory.dll' was found but could not be loaded. Ensure t
I'm having some issues with our FME Server which I don't understand. Every now and then, when running a nightly scheduled job, a FeatureReader fails to read a CSV file. The log returns:Trying to find a DYNAMIC plugin for reader named `CSV2'Library 'D:\Program Files\FMEServer\Server\fme\plugins/CSV2.dll' was found but could not be loaded. Ensure that all the dependent modules exist for this libraryModule 'CSV2' is unavailable for use with this FME editionWhen I resubmit the job, everything works fine... which is great for the data being processed, but harder to debug. The issue feels somewhat familiar and I did find similar questions but not related to CSV2.dll.I'm quite sure this is not related to desktop/server versions. Version is 2019.1.2.As far as I am aware nothing has changed in the installation, I do know the certificates were replaced recently but I doubt this has anything to do with it. Not sure where I should start looking, can anyone point me in the right direction? Update: