A space to discuss FME Flow
Recently active
What would cause an FME Server job to successfully complete with no errors, but not create the expected output? In this workbench I have specified to write a file GDB to a zipped folder, which works as expected when running from Desktop. The log file from FME Server shows that 500k features were written as expected, but the file is not present in the output folder. I'm running this with the Job Submitter Service. I originally thought it was a permissions issue, but that does not seem to be the case since I didn't receive an error.
https://community.safe.com/s/article/FME-Server-Stored-Cross-Site-Scripting-XSS-Vulnerabilities In this latest advisory it's mentioned that there are two specific XSS issues, and two different CVE assignments. That's all well and good, even if there is a ton of lacking pertinent information. The problem I'm having is that this CVE (https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-38339) was assigned to this specific advisory but there's zero mention of it. Does anyone know specifically why 2022-38339 was assigned?
I am trying to email a file geodatabase. I quickly learned that FME Server doesnt like folders and will only zip and email files. So I went back to the desktop client and set the gdb to be zipped for output. Tested it on local storage and I get a valid zip archive that contains the gdb folder. I then publish that workspace to FME Server and run it with a geodatabase folder parameter of $(FME_SHAREDRESOURCE_DATA)\\BuildingFootprintQC\\BFP_overlaps.zip\\BFP_overlaps.gdbOR$(FME_SHAREDRESOURCE_DATA)\\BuildingFootprintQC\\Neither works. The workspace runs without error but generates no output. I logged into the host server and checked the resources folders to make sure the zip is not there and indeed its not being created. How can I get FME Server to follow the desktop function of zipping the output so I can tell the email action in the automation to send the gdb as an attachment? Edit:I checked the log and the entry MULTIREADER: output will be zipped only appears when running on the deskt
Hi, I've recently completed a FME Serverdeployment on Azure Kubernetes and I'm positively thrilled about thecapabilities of FME Server on this environment.The automatic scaling of the Azure node pools for dynamic engines makes it very easy for large requests to be handled easily by FME Server. When you assign a number of engines to a specific node pool with property: “compute” via a helm upgrade command - name: "dynamic-group-1" -> - name: "dynamic-group-1" engines: 2 engines: 8 type: "DYNAMIC" type: "DYNAMIC" nodeSelector: nodeSelector: property: compute property: compute Azure Kubernetes handles this perfectly with autoscaling and start up these nodes and engines without issue.However, I would expect that when these engines are not in use FME Server
Hello,I want a trigger in FME Cloud with an Emailer 24h/7. When I receive an email, I run a process. If I receive no email within an hour, do I still need to pay for that hour of instance running, even if I ran no process?Thank you.
I am trying to configure FME Server for HTTPS using a client provided pfx certificate. I have used this documentation, successfully completing steps 1-6. However I'm getting this error:I suspect there is an issue with the certificate, but I'm unsure where to begin looking, or how to fix. When looking at the certificate details, the Owner CN is '*.<client_website>.com, which differs from the local host FME Server is installed with. Is this the same as the hostname?
In a single workbench, I have automated some processes. One of those generates a report in Excel format. I saved this file in the Shared resource folder on the FME server. The Excel attachment is sent out at the end of the translation. Since last week, the tool hasn't delivered emails to recipients because the emails are too large. When I run the tool on the desktop and save this attachment to my machine, it shows a few KBs, but on the server, it shows 10MB. I compared both outputs (one from the FME server and one from the desktop) and neither shows any differences. I would greatly appreciate any feedback and advice!
Hello everyone, and welcome to What's Up Wednesday. New FME ReleaseI noticed that last week we released FME 2022.1.2 (build 22627). According to my information, the updates include: Snowflake Writer: multiple fixes and improvements, including Bulk writing supportTransformer fixes: SQLCreator/SQLExecutor, DuplicateFilter, FeatureWriter, DatabaseJoiner, 2DGridAccumulatorFormat fixes: Revit, 12dXML, SpatiaLite, Cesium 3D, GTI ViewerListSearcher: add a case-insensitive option I don't think there is anything major in there, so before rushing to update - especially at the enterprise level - I suggest you check the change logs to see if there are specific items that affect you. Incidentally, the FME Hub has already been updated to support this new build. Knowledge Article UpdatesI've started to get a handy automated message each week (thanks, Liz) that tells me which knowledge base articles have been updated. This week it is: FME Server Troubleshooting: AutomationsFME Server Troub
Hi, I'm new to FME server and I configured an smtp account to send system emails however something wrong is happening as no emails are actually sent.The configuration seems correct in Admin panel (configuration > system & email > email service) (correct info and validation test pass). However, the simple test of running a workspace with email notification on status does not work. Checking the subscribers logs (resources/logs/core/current/subscribers/emails.log) gives quite odd information: "801031 : Invalid SMTP server." I used the same SMTP configuration using an emailer transformer onto a workspace; everything works fine when running on the server. So I'm a bit confused here about why it gives this error since all other stuff seems OK ... (side note: I'm using infomaniak.com infrastructure for the mail server and they does not ask for 2nd auth or other protection for sending email from other apps) Thanks in advance!
Hello,I published a workbench on FME Server enabling version control.After having published I noticed that I am using a wrong number in the text. instead of -214 it should be -216.Can I change the text ? Or delete the version ? Thank you!
Hi,I have installed FME server, but after installing everything successfully I cannot see the fields for login in the web page.I have checked my firewall , couldn't find any blocker from there. I dont have any additional antivirus installed in my machine. Please suggest how to resolve this issue.
I need that every user who launches FME Workbench has set paths to a shared folder, in order to share connections to databases. However, I do not find where FME saves this information. In the Windws registry?
Quick question about the Windows account that FME Server uses. If I write an FME script that reads from, say, a CSV file and writes to an Oracle table, the Oracle account that gets used is specified in the connection parameters. But what Windows account
I've only just now noticed that the Tools repository appears to be hidden. I can still use Filter Message and Log Message actions in Automations (although I do get a warning when opening an older Automation). Can anybody confirm this?
I need to download files from a WebDAV source using FME. Is there any experience around in doing this directly in a Workbench (e.g. HTTPCaller)? Or will I need to integrate third party scripts (e.g. Pyhton)? What would be a feasible and efficient method?
Hi, I am migrating my fme server installation to a new server, but I encountered error during the restoration process in the new fme server environment. The backup is from FME Server 2021, and I am restoring the backup in FME Server 2022. I have captured the error message and attached in this post. I would like to ask for some guidance here and hope to hear from the others who faced the same problem before.. Thanks.
Hi all, I'm playing around with FME Server Apps and I'm trying to return errors when uploaded files may be invalid. I used the Terminator transformer to set a custom error and can see in the Fail Status message in the job summary. But when the app hits the error I'm returned with 'We don't know what went wrong' . Has anyone managed to return a proper error? Cheers
Hi, I have successfully followed the below resources to get the SharePointOnlineConnector up and running on FME Server:https://community.safe.com/s/article/How-to-create-a-Sharepoint-Web-ConnectionI created my own Azure application to do this, and successfully test the authentication. The workspace works fine for a few days, untill the request token expires, it then fails to generate a new token until I manually reauthenticate. Is there a way around this @jlutherthomas ? I'm using FME Server 2021.1.1 Build 21619 - win64 Thanks
We have setup a FME server with app gateway as the load balancer. App gateway (App Gateway IP) is mapped to Azure Front Door. Azure Front door URL is mapped with the public DNS. When user logins using SAML credentials (IDP: Azure Active Directory), user login is successful but it is redirect the application to Application Gateway URL rather than public URL (which is mapped to Azure Front Door).
User has a workspace in a repo owned by them. How can I change the owner?Under items under user management I can not see category workspace.
Hi,Whenever I am going to run any workspace in FME server- I am getting a error message that "There was an error submitting the job", but I am unable to see any detail/log for the same.
HelloI just started using Automation in FME Server 2020 and plan to use it more by migrating my existing scheduled jobs.I have a workspace which runs a batch script. It uploads multiple files to an SFTP server using WinSCP.com commands withing the script.The workspace in question, in "Automations" is connected to 2 Email (External Action) 1 - Success then send an e-mail2 - Failed then send an e-mail with 2 attachments (WinSCP.txt & Error.txt)Number 2 is the problem. So I thought I'd use Global Keys for that purpose ({Global.Email_Attachment}{Global.Email_attachment1})Right now it's failing before when the 2 parameters are associated together I get an error in the log stating that the file can't be found.Is that possible and if so how do I include both Global Keys within the Email Attachment field? If not how do I proceed?Thanks Sameer
The current Automation External Action Email does not support multiple attachments and I know I can create one ZIP file, therefore I need to continue to use the existing Notifications (Classic). My existing workflow is FMEServerEmailGenerator -> FMEServerNotifier ->What do I need to do in the Workbench to pass the "text_line_data" to the Automations External Action Topic?orIs there another method of sending an email with multiple attachments (not ZIP file)
I've been trying to move from the classic Notifications to FME Server Automations for sending emails. In the past I had a Subscription and a Topic set up which I used to notify for sending emails. Going forward, I want to use an Automation with a Trigger (based on my Topic) and an Email Action. The Trigger works fine and I've managed to map the JSON keys from my notification service to the relevant fields in the Email Action (some more documentation around this would have been helpful!). What is missing is sending multiple attachments at once in a single email. This worked fine through a Subscription by creating a list within my notification (email_attachment{}). How can this be achieved with an Email Action? The manual selection appears to allow only for single files, too. An additional note on this - I've noticed that (within the Email Action) sometimes the fields for attachment and email body are being cleared out when navigating away and back to the Automation screen (
Hi everyone, I know how to read just 1 text file and use StringSearcher to extract string from the content. But how do I read "multiple" text files "automatically" and extract specific string from the content in each one of them? Thanks in advanceHoward