Question

FME Cloud dgn writer messes up character encoding.

  • 22 October 2021
  • 5 replies
  • 27 views

I have FME desktop 2020.1 installed - when I generate dgn file everything looks ok, however when I publish it on cloud accents and diacritics go crazy.

My local machine runs on win-1250. FME Cloud / Server run utf-8, is there a way to make this not mess up my texts?

I have tried AttributeEncoder with no success.


5 replies

Userlevel 5
Badge +29

Hmm seems you're not alone

https://community.safe.com/s/question/0D54Q000088EA6W/i-have-problems-with-special-characters-eg-%C3%A4-%C3%BC-etc-in-dgnv8-windows-i-use-fme-2019-in-the-fmecloud-on-linux-i-have-a-postgresdb-for-my-data-i-believe-this-is-related-to-the-dgn-writer-storing-encoding

My guess is that the reader just assumes data are in the system encoding - there's not option to choose the encoding. My system is encoded in win-1252 and both are a little bit messed up.

 

I see on the writer that there is an option to specify the encoding of a seed file in the output. Have you tried using a seed file and setting the encoding to win-1250? Perhaps this is a way to control the output encoding for the whole file?

Hmm seems you're not alone

https://community.safe.com/s/question/0D54Q000088EA6W/i-have-problems-with-special-characters-eg-%C3%A4-%C3%BC-etc-in-dgnv8-windows-i-use-fme-2019-in-the-fmecloud-on-linux-i-have-a-postgresdb-for-my-data-i-believe-this-is-related-to-the-dgn-writer-storing-encoding

My guess is that the reader just assumes data are in the system encoding - there's not option to choose the encoding. My system is encoded in win-1252 and both are a little bit messed up.

 

I see on the writer that there is an option to specify the encoding of a seed file in the output. Have you tried using a seed file and setting the encoding to win-1250? Perhaps this is a way to control the output encoding for the whole file?

Can you direct me to where I can specify output file encoding when using seedfile? I am most definitely using seedfile that is also created on that computer so it should be win-1250 encoded. All I see in the writer is the path to the seed file...

Userlevel 3
Badge +12

Can you direct me to where I can specify output file encoding when using seedfile? I am most definitely using seedfile that is also created on that computer so it should be win-1250 encoded. All I see in the writer is the path to the seed file...

Hi @Radek Žďánský​, when adding the DGN (v8) Writer to your workspace, you can click the Parameters button to open the Writer Parameters window. Here, you can change the Seed File Character Encoding to match the encoding of your FME Cloud.

imageHope this helps!

Can you direct me to where I can specify output file encoding when using seedfile? I am most definitely using seedfile that is also created on that computer so it should be win-1250 encoded. All I see in the writer is the path to the seed file...

Hi @danminneyatsaf​ ,

Unfortunately when I add dgn v8 writer, all I see is this. No setting up of seed file encoding for me.

writer_options

Userlevel 5
Badge +29

Can you direct me to where I can specify output file encoding when using seedfile? I am most definitely using seedfile that is also created on that computer so it should be win-1250 encoded. All I see in the writer is the path to the seed file...

Yeah it looks like this was added in FME 2021...hopefully you can upgrade?

Reply