A space to discuss FME Flow
Recently active
Hi, I have a number of outgoing webhooks from MS Teams that call tasks to run in FME Server that then respond back with a message in MS Teams. That's great but I would also like to be able to pass messages into parameters. e.g. From MS Teams send this: @FME Server 'check this' The 'check this' could then be received into a new parameter and used by a workbench job. Has anyone had any luck doing this? Many Thanks!
It seems like this should allow for more itemized day selection, week selection, month selection. We want to setup multiple automations and it does not seem like I can do that, exactly.
Can a subscription of type httprequest have a target URL that is using HTTPS instead of HTTP?
FME Server 2021.2.6 We have an automation which downloads attachments from an email to an UCN path. When the automation is triggered, it logs the following error:2022-11-28T16:43:49+01:00 | 809004 : \\uncpath\image002.png : Failed to download email attachment. Download location "{1}" is not available and could not find an appropriate alternate location.But when we look in this specific folder, we see that the attachment is downloaded successfully.Questions we have are:Do we try something which is not supported?Can we solve the error log?
Using the instructions, we were unable to use Chrome create the .cer file. We had to use Internet Explorer. In the Verify HTTPS configuration step, localhost produced an insecure connection although using the hostname produced a secure connection. How can this issue be corrected?
How do I upload/post PDF files to Survey 123 Portal? I tried using both the put & post options in HTTPCaller transformer as well as FeatureWriter. It appears to work as I did not encounter an error message but the files don't get actually written in the portal. I guess it could be the HTTPCaller settings but I'm at a lost how to set it. Please advise what I'm doing wrong , or any sample FME script with httpcaller settings would be greatly appreciated. Thanks in heaps! Wilfredo
Hi team,with the deprecation of Basic Authentication coming up in October later this year (Deprecation of Basic authentication in Exchange Online | Microsoft Docs),it's been suggested we move across to OAUTH for accessing emails via FME Server Automations. I'm a little stuck on how we can do this? There doesn't seem to be any OAUTHcapability within the templates? Any suggestions on how we can achieve this?
I have a couple of reasonably complex workspace that I have used the Worskpace reader to extract some data from. I have attached the image below to show where I am currently at. I have all the data but my question is "WHAT NOW", how do I use this data to it's best, and to explain what is going on in the workspace to the average person so it is understandable, and out put in a user friendly format. I thought someone may have some examples of what they did and how they used their data as documentation. I have watched the Video from tensing which was good but it really doesn't explain the how and final documents very well. Thank You.
I have a workspace that needs to run when there is a new file in a SharePoint folder. Is it possible to set up an automation that would work similar to Network or Resource Directory?
As far as I understood from the documentation, the self-hosted FME Server (installed on my own server) can be also licensed by CPU (Dynamic Engines)?That means that I have a full control and security (especially in terms of data privacy, etc) of FME Server like self-hosted FME Server with standard engine(s), however in terms of license it acts similar to FME Cloud?So if both questions are correct then the difference between self-hosted FME Server licensed by standard engine(s) and self-hosted FME Server licensed by CPU (dynamic engines) in regards to license is that the client pays for an extra standard engine only once, but for CPU Usage as long it in hours takes - continuous payment?
Hi, I have tried to follow the suggestions in this thread to connect to Mapillary API without success.https://community.safe.com/s/question/0D54Q00008vZLePSAW/hi-have-anybody-succeeded-in-connecting-the-mapillary-api-v4-with-fme-workbench-i-get-stuck-on-an-internal-server-error-when-i-use-httpslocalhost-as-redirect-url-in-the-oauth-20-webservice-authentification I am using these settings:I am just getting a login page when I test the service: Any suggestions? The result is the same with http://localhost and https://localhost. It is the same when adding Authorization under HTTP Header for Retrieve Token Parameters. Anyone got any suggestions on how to connect to the API and for example get coverage tiles.
We have FME Server hosted on a docker environment. We are using AWS, for database we are using RDS postgres, and for storage, we are using EFS. On one server we are running all core components using docker-compose. and we have lambda-based engine deployment using separate EC2 servers. Of course, both core and engine are using postgres RDS and EFS. What would the upgrade process look like? Our goal is to upgrade without losing any repository, server configuration, job logs, automation, schedules, etc.
I tried to uninstall using the FME Server installer (EXE) file, the status stay at "removing files" for long time without progression. I tried to uninstall the server from Windows control panel, the process hangs as well. I need to reinstall the server from C:\\ to D:\\ drive, the repair does not allow me to do that. Please advise how I can remove the Server 2021 from Window 2019 server platfor. ThanksHelen
Hi,My organisation provided me a CA signed PFX certificate.I have followed the step-by-step guide to update server.xml, web.xml and content.xml, etc.I am able to restart the FME server service.However, when I use https://locahost/ or https://<server name>/fmeserver/I contantly get the message "This is site can't provide a secure connection", and ERR_SSL_PROTOCOL_ERROR.click the (i) at the URL address bar shows NO certificate.I checked the other internal site, it states "This site does not have certificate."I couldn't complete the export and import Base-64 encoded X.509 cer file.How can I move forward from here to complete the HTTPS enabling?ThanksHelen
I have found specifications for desktop and server machines, but I would like to confirm what specifications are needed for a license server. What are the minimum requirements and suggested requirements?Thank you for your time,Julia
Hello! I am trying to schedule a workspace to run 17 markets. Workspace is the same for all 17 markets. After the first market ends, I want it to start the second one. I know workspace runner on FME desktop that kicks off markets one by one.The scheduling of the two markets on the FME server worked well for me. Due to the fact that I have 17 markets to run, I was wondering if there was a better way to do this. I would appreciate any advice you can provide.
Hi, I have an automation workflow that is executed by dropping a file in a target directory. If the file is a ZIP archive (filter action), a hosted FME workbench should be triggered. The workbench expects a path specification (path of the ZIP file) as user parameter. However, in the configuration interface of the automation action I don't have a dropdown to access an output key of the trigger ({file.path}). Is there any configuration to be done in the workbench to handle output keys? Edit: Using FME Server 2022.1.1 - Build 22623-win64
Hi all.2022.2 introduces triggering an automation from a webapp, in addition to triggering automations in numerous ways already defined.One such triggering is "FME Server Topic notified".Can I create a workspace, uploading it to FME Server, and have this emit such a (custom) topic, in effect triggering the automation to run ?If so, I could potentially create a webapp for such a workspace, and achieve the same functionality, couldn't I ?Alas, there are no immidiate transformers that allows such emission, but workspace FME Server Parameters include FME_TOPIC and FME_TOPIC_MESSAGE. Can they be used for this, and if so, how ?Or must I resort to using the REST interface ??
We have two FME Server environments als on two different computer environments. I copied the content of the .fsproject file from one computer environment into the other computer environment by means of copy/paste into a text file and then changing the extention to .fsproject (it's a bit of hack). No idea by doing that the .fsproject will be altered. However, I am then trying to import the project(.fsproject file) into the 2nd FME Server environment via "Projects" < "Manage projects" <"import". I am dragging the .fsproject file into and then clicking on "Import". After running, I get the following error: I changed our domains name to "nameofname" for security reasons.COM.safe.fmeserver.configuration.migration.FMEConfigurationException: java.io.IOException: Error on ZipFile \\nameofdomain\aplroot$\APLDATA\FMESERVER\resources\system\temp\tomcat\22e287e6b3514dc9b4dd095174c01fb7\restServerRestore.fsconfigPROJECT IMPORT : FAILURETask Failed : Please refer to above message I tried us
I have points and lines, I want to snap the lines to the points, both edges, ends, and sides. I tried using the snapper and also tried using the anchored snapper, but I still don't get to snap some. I have used intersection transformer, it does the major part of the snapping but creates new points at any intersection without a point. I really would love to do this snapping based on relationship (attribute)
What I've done so far ... I've selected a .fgb from a location (the location will stay the same, however, there will be multiple .gdbs that come and go over time) I added a reader, Schema (Any Format), filtered for *.gdb.I added a FeatureReader, with a WHERE clause to only look for ... @Value(fme_feature_type_name) LIKE '%M_CSCL%' ...However, the way I've set up the FeatureReader doesn't work in it's current state.Any hints/improvements/better ways to achieve this would be appreciated, see the attached workspace.thanksJeremy
For FME Server what are the practical differences between internal and remote Version Control? What considerations should we to take into account about when choosing between them?
Hello,I would like to ask about Rest API v3 support. For how long will it be supported yet, before it will be needed to switch to v4?
Hi there, I am trying to use FME to automate some user management for FME Server. Specifically I would like to schedule a workspace to remove any Azure users that are not members of a role. I have worked out how to list the users and get their roles, but I can't work out how to go from this json array: ["user:admin","fmeadmin","fmesuperuser"] to the integer value 2. Can anyone please help me drop the "user:..." part from the array and count the number of items that are left over? Thanks!Marc
Hi, is there an alternate solution available from safe to replace the basic authentication for IMAP and SMTP? Since Microsoft will stop supporting this solution soon