Creating and organizing workspaces. How to use Workbench.
Recently active
Is it possible to use a negative list index in the AttributeCreator? If not possible, why not? Any technical reason or just not implemented? Should I create an Idea for it?Workaround is to use the ListIndexer, and AttributeRenamer but this is not really intuitive nor quick. Unlike most things in FME.
We have a service published on FME Server that uses an OAuth Web Connection (to Salesforce). The Web Connection is published to FME Server, and has been "authorized for use" from the FME Server Admin UI. Our service works fine for a few hours - presumably the lifetime of the authorization token. But then it starts failing with "unauthorized" errors, which are immediately resolved if someone logs into the FME Server Web interface and again Authorizes the web connection.It's as though the token refresh process never runs.Is there any way to troubleshoot this on FME Server (e.g. some sort of debug/verbose logging on the fmeoauth service)?
I understand that under the Tools menu there is an "Edit Header" option – but this is done per workspace. Is there any way to set a default Workspace Header so I can always have my favourite settings on each new workspace I author?
Hi guys,I have data which look like this:|ID|Number||1|1||1|3||2|1||3|1||3|2||3|3|I need to group them by ID and pick up only rows with highest Number value. To get such data:|ID|Number||1|3||2|1||3|3|Any idea how to accomplish this?Thanks
Hello, I have a folder of photos with filenames that contain pointid's (e.g. 123456_photo1.jpg). Each point may have more than one photo associated with it. So there may be many photos containing the same point id in their name. I'd like to create a list of photos per point and assign the list to a field and write to geojson.I tried using the tester and feature merger but I can't seem to get it to work. I basically want for every point id, check if the filename contains the point id, add photo file name to list, then assign list to field called 'photos'.Thanks!
I've added 7 individual Feature Types to my Workspace and want to expose fme_basename and mapinfo_type for each of them. Is there a quick way of doing this that will save me from having to edit the properties of each Feature Type one by one?
Hi there... I a list containing adress inforation. The lenght of the list varies from featur to feature so I need a flexible solution... The list looks like this: _list{0}.name = "Company 1" _list{0}.zip = "ZIP-Code 1" _list{0}.city = "City 1" _list{1}.name = "Company 2" _list{1}.zip = "ZIP-Code 2" _list{1}.city = "City 2" _list{2}.name = "Company 3" _list{2}.zip = "ZIP-Code 3" _list{2}.city = "City 3" : _list{n}.name = "Company n" _list{n}.zip = "ZIP-Code n" _list{n}.city = "City n"As you see...the list is of dynamic length... The task is now, to write some of the list elements into attributes:_list{0}.name => name1 _list{0}.city => city1 _list{1}.name => name2 _list{1}.city => city2 _list{2}.name => name3 _list{2}.city => city3 : _list{n}.name => name_n _list{n}.city => city_nSo I need to create a dynamic number of attributes. I tried the a
Dear Support,I am currently trying to execute a workspace and I have problem with the following error:Unable to create worker; parallelism level may be too high for the translation requestedTransformer 'pointFetcher': Unable to create worker; parallelism level may be too high for the translation requestedFor a set of 15000 polygons, I try in parallel and in a custom transformer to read pointclouds in a external database and then compute statistics for those pointclouds. Still within the custom transformer and in parallel, the input polygon is written with its statistics as attributes. By doing so in parallel and in a custom transformer, I am not overwhelming my RAM. In fact, as soon as the statistics are computed, the variables containing the pointcloud and the statistics for a polygon are erased from the RAM.When launching this process in a minimal parallel processing mode (4 parallel subprocess) and for 1000 polygons, I do not encounter any problem.When I launch the workspace
Hello,I manage an FME Desktop 2016.1.3.2 environment running out of Citrix XenApp 7.6.300 as a Published Application.We are having issues with anything that uses Parallel Processing, We have managed to get it working (no idea why it started working) and it was working well for some months, then recently it has just stopped with out any real reason. No changes have been made to the environment.Some things I have found.When running a workspace that has Parallel Processing turned on (any level) via the Citrix Published FME it fails at the stage"Storing feature(s) to FME feature store file E:\\MultiProcessor_11245\\inspector.ffs"Then we get an error box that "FME EXE has stopped working" "Close the Program"Run the same workspace but turn off Parallel Processing - works fineIf I manually RDP into the XenApp Server as the same account and run the exact same workspace with all the same settings, including Parallel Processing... it works every time. To me it seems
Hello,I have a simple dynamic workflow with Shapefile reader and Oracle writer (something like that) where I had a counter to add an ID in a new column "OBJECTID". This works well but my new column is added at the end of the schema. Is there a way to put this as first column?Thank you!Maxime
Hi, I have dataflow where I filter my data by an attribute. This results in 100+ output ports. After that I will perform the exact same transformation for every output port and write the data in a separate file. (Yes, I do need to filter first.) Of course, I can create a custom transformer for my transformation that follows (see screenshot) but I'm wondering if there's a way so I don't need to add the transformer and a writer to my workspace 100 times?Any suggestions?I'm using fme desktop 2016
Hi Friends,two questions :1. We can type the attribute names in this text field, but we cannot pass it like variable or text string(list). How can i pass this published parameter to "Attributes to remove" field to the writer dialog box? 2. If i write to shape and it crosses 2gb size fme gives error. how vcan i split the shape file if it crosses 2gb? (like fme splits v7 dgn file size in V7 writer)Explanation :My fmw has Dynamic reader and writers. I am reading from oracle spatial (every time input tablename changes, user types in table name through published parameter) and writing to any 4 formats.(shp, tab,dgn and acad) here my fmw is dynamic. there are some attribute names that i dont want to write to destination. user types in these attribute names(space delimited). through published parameters. Every time this list changes and different attribute names comes in. In the Dynamic properties, there is a provision called "Attributes to remove". Now I have two ques
Hi,In FME Desktop I can add a Header to know the time spent on each transformers.FME_PROFILE_RESULT_CSV "filepath".How can I do this on a FME Server?
I published a simple workspace to the FME server's Job Submitter service with the Job Completion notification posted to JOBSUBMITTER_ASYNC_JOB_SUCCESS/FAILURE topics. Then I published a second simple workspace (Creator and Logger just for testing) and add it to the subscription to the same topics. I would expect when I run the 1st workspace and at the end of it, the 2nd workspace should be run. But it did not. I can see the 1st workspace was run in the Topic Monitoring, but didn't see the 2nd job to follow up. Did I miss anything? I also tried using a new topic, instead of the out of box JOBSUBMITTER_ASYNC_JOB_SUCCESS/FAILURE topic, but no luck.
Hi,I'm using FME to check the log files of previous runs, testing for errors.I'm now getting notifications of errors in a set of log files, that has been generated by running a workspace via "WorkspaceRunner". The error is bogus, however, so it messes up my overview by cluttering it with false positives.The dependent workspace is called with two parameters: the path of the (xml) file to check, and a path to the desired log file. This log file path contains a dash, so I get this error:BADNEWS: String value `WorkspaceRunner_DanDas: Running FME Workspace xxxxx.fmw with command line:' contains invalid characters and could not be converted into an integer (stfutil.cpp:802)A typical log file name may be: CONTROL ARWOS XML - TV-Inspektioner.logHow can I avoid having FME attempt to do a bogus subtraction in my string value ??Cheers
I have an attribute with integer value called number of folders x for a single feature, and I would like to create X number of features. so I can create c number of sub-folders using filecopy.
Hello Everybody, We have two FME server installed. None of them we cannot accesible from outside server. I need to make it web accesible. Please guide me. Because I want to got the data download or to run a workspace using the generated URL from outside. Thanks
I am trying to connect to our carto database, but are getting HTTP error 404, and also connection refused 443.How do you connect to a Carto Database?I am using out url address: com-luim.geografia.com.au and API key
I frequently use batch scripts to run series of workbenches in cmd.exe. I would really like to see the contents of the 'transaction window' or log file displayed in the cmd.exe window. I know I can look at the logs, but that is an extra step and not as useful.Normally what displays is something like this, which doesn't explain what is happening in the transactions window or log file. I really want to display this stuff in real time (not after the transaction complete): Have I missed something, or is it not possible. Thanks in advance for your help
Hi,I am using the 64bit version of FME 2017.0. In my workspace I am writing to an Oracle Spatial Database. I have 64 bit versions of Python and Oracle instant_client installed.At the end of the running the workspace after the TRANSLATION SUCCESSFUL message I receive the following error message (repeated 3 times) Traceback (most recent call last): File "C:\Apps\FME4\/python\fmesite.py", line 6, in <module> from fmeobjects import FMESessionImportError: DLL load failed: %1 is not a valid Win32 application.Any suggestions as to what is causing this?
Hi everyone,I am having trouble with downloading SDF output as a data download service.The workspace itself is really simple:- 1 SDF reader, reading a file containing 10 features;- 1 transformer;- 1 SDF writer, creating a file containing 10 features. When this process is executed from the FME Server environment as a job submitter service, there is no problem. When the same is executed as a data download service, I can see in the log that 10 features are written. The download link also shows the output .sdf file, but it contains 0 features in data inspector (instead of 10). When we write to e.g. shapefile as a download service, there is no problem. So, to summarize, it appears to be impossible to use SDF files in a data download service? I know it has worked before, so I am wondering if anyone had the same problem? Suggestions how to solve this? Thanks in advance!
Hello,I am trying to authorize a web connection to my Dropbox account on FME Server so that a file can be incrementally uploaded.In the Dropbox Developer portal, I created an app where I got my client id and client secret. As for my Redirect URI, I tried using http since my server is behind my network’s firewall, but it only let me use https. In my FME Server’s Web Connections, I updated my client information to match what my Dropbox app had. When I tried to authorize it, I got an error saying the site could not be reached.Is it because my URI is incorrect, and/or if there are other configurations that need to be done? My colleague mentioned that maybe we have to make the server public. I am not sure. Thanks!
FME Server: 2015.0 bld 15250 Occasionaly when I publish workbenches to FME Sever (which run fine from workbench) I get a failure and upon investigation in the log see this error once or twice: Creator_CREATED Feature Counter -1 3(TeeFactory): Creator_CREATED Feature Counter -1 3: @LogCount: Cannot save feature. Either function was missing appropriate configuration line or a FFS writer initialization failed The error does not appear to be down to the workbench as sometimes a reboot of fme server, and then republish the workbench sees the error go away without me (apparentely) changing anything in the workbench. This is fine on our sandpit box, but not so good on production. Has anyone come accross this issue? I've had a search of the support docs and didn't spot anything. We're running server with active directory authentication on. Any pointers would be much appreciated. Nick
Hi, I am working in FME 2014. I am trying to create a workspace that will have a reader grab all xls files from one folder (with multiple schemas), re-project the xy coordinates to two new attributes (x, y), and export the data to multiple xls files based on file name and new projection. Before the workspace is run, the user must manipulate the xls files to have columns with original coordinate system and original x and y coordinates. The headings "Original_Coordinate_System" and "SourceX" and "SourceY" are the only common column names between all the excel files. When I run the workspace I get an error saying "Error fetching dynamic schema definitions from reader `XLSXR_1"Attached are two xls worksheets as an example, and two screenshots to show a portion of the script.Would anyone have any suggestions that I could try? Thanks in advance.
I have a template geometry (tree.dae) and like to copy them to different locations. The locations are given with points (x, y, z) including a scale factor as an attribute in a shapefile. My idea was to move the template geometry with "Offsetter" and the parameters from the point geometries. How can I manage that in an FME workbench? I couldn't find a transformer for that until now... Thank you for your feedback.