A space to discuss FME Flow
Recently active
Need to install arcgis pro 2.9.5 on the FME servers so FME has access to ESRI projection engine. How I can proceed there is any documentation that what are the prerequisite and how to install.
I need to perform FME server (2022) silent installation in EC2 machine, do I need to create response file or there is any script that we can directly execute using cmd.
I'm very new to the concept of deploying things within a Docker environment. As far as I know, FME Server works perfectly fine with this but what about the interaction with FME Server after it´s up and running. Are you as a workspace author just uploading your workspaces like you do on a normal FME Server on a regular Windows plattform? Same with FME Projects? My second question is if there is a way to use Docker and Jenkins to install FME Projects instead of the normal way through FME Server Gui import/export. RegardsStefan
I am having issues with using the payload that is being sent to the webhook in FME server. I have setup a webhook, I watched this video: https://www.safe.com/webinars/hook-line-and-sinker-reeling-in-arcgis-webhooks/ But I cannot set the same values in my ParameterFetcher and my Workspace on FME server is not allowing me to set anything with webhook. I have the webhook created and I am able to log the webhook message to the logs and see the expected output. I am having issues sending it into an fme workspace.
Hi all.Has anyone attempted this ?I'm exploring the possibility, and although it ought to be possible, it fails to validate.One this puzzles me though: All configuration examples I've googled, mentions both an EMAIL ADDRESS and a USERNAME, which is also an email. And they're different when accessing a shared mailbox.But the automation trigger only has one "IMAP Email Account" setting.Is the IMAP trigger missing a setting ?Cheers.
I am trying to set up an automated fme workbench to run once a day. I ran the Workbench in FME Server and it ran just fine without error. All this workbench does is run a SQL Creator that sends the data to an excel writer (one for each type of permit) and then it saves the files into a folder on FME Server. That is all it does. The version is FME Server 2022.2.1.
Hi everyone, I'm trying to convert a PDF file containing geographic data into a shapefile format using FME. There is a lot of work that has been going on in the recent past on this, and even I had tried a few online tools, QGIS plugins and now playing around with FME using a few transformers.Actually, my spatial pdf file has the transmission lines network that includes transmission lines, substations and the geographic region with text information provided that represents the points and lines on the file with a descriptive legend.Since I couldn't efficiently work with that file as it is 15Mb and has around 800k entities, I am working on a sample pdf.Can someone guide me through about what concept can be applied to perform this?Thank you.Attached:wallawalla.pdf: sample fileERCOT: Practical file
What could be a reason for uncomplete login form? It looks like this:Looking into dev tools I see two errors popping up:DevTools failed to load source map: Could not load content for https://<domain>.com/fmeserver/dist/app/libs.min.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE/fmeserver/#/home:1 GET https://<domain>.com/fmeserver/ 401DevTools failed to load source map: Could not load content for https://<domain>.com/fmeserver/dist/app/libs.min.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILUREjquery.22789.min.js:2 GET https://<domain>.com/fmeapiv4/info/login 404Other than that the server appears to be working as expected - health check returns the following:{"status":"ok"}database is there and I was able to connect into it, license has been applied successfully, tokens work, in general all API based functions work as expected. The only problem is to use the front end... Server info (got via API..
Hello. Using FME Server 2022. I have an issue monitoring our FTP. I want to monitor all subdirectories for changes. I keep getting an error where "/." is being appended to the "Path to Watch Directory" an infinite number of times. I get thousands of errors from the automation. Here is the error message:When I check into our ftp client logs, here is an example of the file path that FME Server creates: /upload/Directory/./././././././././././././. Why doesn't the trigger just detect and stop at the directories that exist?
Using my basic FME skills, I've been able to automate the download of the OS Mastermap Topographic Area, Line and Point but am struggling over how to maintain the changehistory feature collection type which FME wants to insert a single value. Being a common task amongst many GIS users, I would hope there are some models out there....?
Hello There I am using FME to generate a WebSocket stream, on the desktop we are getting the valid JSON format, but when published to the server I am getting an extract Caracter ( " \\") backslash --------------------------------------{ "ws_publisher_content": "{ \\"type\\" : \\"FeatureCollection\\", \\"Features\\" : [ { \\"type\\" : \\"Features\\", \\"geometry\\" : { \\"type\\" : \\"Point\\", \\"coordinates\\" : [ 48.740187789955101, 27.965531016954699 ] }, \\"properties\\" : { \\"truck_plate\\" : \\"YHSR2379\\", \\"latitude\\" : 27.965531016954699, \\"longitude\\" : 48.740187789955101, \\"event_type\\" : null, \\"event_color\\" : null, \\"severity\\" : null, \\"status\\" : \\"On_Road\\", \\"counter\\" : 1562, \\"time_stampe\\" : 20230115061550 } } ]
I have succesfully set up a PostgreSQL trigger and PL/Python function to POST some JSON to a webhook using our on-prem PostgreSQL database and FME Server. It works well following the instructions here and here. However, our PostgreSQL database is moving to AWS RDS and PL/Python3u and PL/Perlu are not allowed as untrusted languages and the trusted versions won't allow the GET/PUT/POST operations. I have seen mention of using ActiveMQ, NodeJS and others and wanted to know if anyone has a working solution in AWS to share or can point me in the right direction?
Hi,I am struggling with install of FME desktop.... This is the detail from the event log.Machine is windows server 2019. Faulting application name: fmeworkbench.exe, version: 2022.7.45.22789, time stamp: 0x63d9e992Faulting module name: Qt6WebEngineCore_fme.dll, version: 6.2.4.0, time stamp: 0x625ef5dcException code: 0x80000003Fault offset: 0x0000000002645d96Faulting process id: 0x37bcFaulting application start time: 0x01d950d3b739183bFaulting application path: C:\\Program Files\\FME\\fmeworkbench.exeFaulting module path: C:\\Program Files\\FME\\Qt6WebEngineCore_fme.dllReport Id: 9d532fef-92d3-429e-b884-fb15a1e27e8aFaulting package full name: Faulting package-relative application ID: We have successfully installed it on another windows 2019 server and it does runFME is also running successfully with build 22789 in the machine where desktop doesn't work.
Currently, I have 15 workbenches in one FME Server Automation. I have it set up to filter through the respective workbenches to find the correct workbench to run, but now I'm struggling with figuring out how to run the second workbench once the first one is run successfully to completion. Through testing purposes, I noticed that my automation would select the correct workbench and then immediately run the second one despite the first one not being completed. It'll run the second workbench after triggering the first one to run. SO, it isn't necessarily waiting for the first one to complete successfully. Is there anything I could add to my FME Server Automation to pause my second workbench until my first one is finished successfully?
Hello everyone, I'm looking for recommendations for a low-code front-end solution to display data transformations from the FME Cloud. The front-end needs to be able to display graphs, as well as linked GLTF and JSON files, with the best-case scenario being the ability to interact with 3D models. I am aware of the option to use Esri, but I am looking for other, more independent and cost-effective technologies. Can anyone recommend any low-code or no-code front-end solutions that would be a good fit for this use case? The FME Server Apps are great and simple to get the user to upload data. But at the moment I have an Html that returns information, with javascript graphs. But this is quite a static approach and I would like to be able to send the data to a databank and then just display the data for the user and let them make simple alterations. I know my around FME, but have very little or no experience with front-end development. I am just curious if there are solutions, without do
Is there a way thru the admin interface to get number of logins per users? or do we need to check the Tomcat logs?
When running a workspace runner in FME cloud, it fails silently with the following error. "FME license system failure: FME is not licensed for this machine. Contact your Distributor." How do you use a workspace runner in cloud?
I have a workflow which calls Workspaces from a python script (Python 3.7.2 running in Spyder). Because of an issue/bug I encountered, I was advised to install the newest version of FME and see if the problem persists. Now I cannot get my scripts to work again. This works:sys.path.append("C:\\Program Files\\FME\\fmeobjects\\python37") import fmeobjects (...) runner = fmeobjects.FMEWorkspaceRunner() (...)runner.runWithParameters(ws, parameters) (...) This doesn't:sys.path.append("C:\\Program Files\\FME2022_2_3\\fmeobjects\\python37") import fmeobjects (...) runner = fmeobjects.FMEWorkspaceRunner() (...)runner.runWithParameters(ws, parameters) All I did was change the path from the old installation to the new one.It fails, saying the module is not found File "c:/data/data.py", line 24, in <module> import fmeobjects ImportError: DLL load failed: The specified module could not be found. It seems it actually finds "fmeobjects", but something else is missing. I suspect some underl
I have a Python script that executes a set of tools in QGIS. I would like to execute this Python script through FME.In FME Desktop, is it possible to run a python script that is stored on disk, and not within the Python caller?
This morning I could use a remote browser to connect (non https) to our fme 2020.1 server. I'd been tasked with upgrading to 2022.1.2. All steps complete, express install, port 80 and the web interface on the server works fine. However, I now cannot connect from any remote browser. Today this has happened on 2 machines, 6 weeks ago I did exactly the same on our dev server and it all worked fine and remote connection is OK. I've looked at the troubleshooting guides etc and all looks ok, I'm close to hoping it just goes away!
The proxy documentation states that proxies are not support for automations. How do I set up my automation and/or proxy to use the FTP Diectory trigger when a proxy is in place?Curently when I add the FTP details to the FTP Directory Trigger and try to validate the connection i get the following error: Invalid - Connection attempt timed out. Verify that the port number and security type are correct. I have tried all the combinations of secutiy settings available and get the same error each time.
Hi folks I know this question has been asked before and there is a way to post json data directly via an HTTP Post Request as described here. The thing is that the web developer needs: An async processA download jobAnd the Job-ID returned back (which would work out using the param "opt_responseformat=json" when using http post - but it returns actually too much information which I see critical in terms of security) Regarding FME REST, I could not figure out how I ever could submit a job together with a JSON to be processed via FME as a result from the users selection on the frontend. The "fmerest/v3/transformations/submit/" would not accept my JSON to be used in the published parameters (I chose a simple text parameter to be fetched in FME for further processing). However, I get a 422 response (unprocessable entity). Do you have any suggestions what I can do here? Any alternatives that might work out better? Any help / hint is appreciated!Thanks in advance!
Hello,I am currently working on a Server App that displays different dashboards.Based on a published parameter the user can select one dashboard and is lead to the one selected. To fascilitate the usage I'd like to introduce a drop-down menu (bearing the names of all published parameters options) on the very same page as the dashboard. So far I managed to do the menu:<form method="post" action=""> <p> <label for="pays">Quel dashboard ?</label><br> <select name="dashboard" id="Dashboard"> <option value="ctrl_job_dr">exemple1</option> <option value="ctrl_job_semaine">exemple2</option> </select> </p> </form> <input type="submit" value="Envoyer"> Just inserting a link (href) does not work in this case for the link does only point to the fmw file.Here's the request I get when I select a dasboard:Does someone has an idea of how to put that into an html for
I was able to insert 847k records out of 1.6M last Friday then it just failed (token was refreshed). This morning, I've disabled / re -enabled versioning in ArcPro and was able to insert 600+ new records using FME. Tried another 600+ and failed with the below error. ArcGIS Portal Feature Service Writer: Encountered an unexpected error. The error code from the server was '400' and the message was: 'Unable to complete operation.'. Details: 'Insufficient permissions [42000:[Microsoft][ODBC Driver 17 for SQL Server][SQL Server]The EXECUTE permission was denied on the object 'i24_get_ids', database 'CORPGIS', schema 'gisadmin'.] [Prod_Address]'ARCGISPORTALFEATURES writer: A fatal error has occurred. Check the logfile above for detailsA fatal error has occurred. Check the logfile above for details P.S. I have tried adding new records using ArcPro thru the same feature service and works fine. it only fails in FME even if I try to insert only
Info:We 2 server for FME Server and web application:-- FME Server has been installed in server with IP B ( xx.xx.xx.123). port 8080- Web Application installed in IP A ( xx.xx.xx.456). port 80The web apps has domain name https://urdomain.comThen, we use proxy so that FME server URL become https://urdomain.com/fmeserver. Problem:During installation, hostname being input as sysadmin with port 8080. After run Workspace, the output can be downloaded via URL shown in figure below.However, remote user cannot access it as it supposely to use http://urdomain.com/fmedatadownload/results/XXXX.zip What have been done:My teammate then change service host from http://sysadmin:8080 to https://urdomain.com/fmeserver which then cause the workspace cannot be run. It cannot be Run as it produce error 404.