Creating and organizing workspaces. How to use Workbench.
Recently active
Working with FME 2013 and running into a problem with the WHERE clause setting on a PostGIS reader. Trying to select a single feature using the expression TRACTCE00 = 001811. I've confirmed in my database that this feature actually exists. However, I get the following error message: 2013-01-18 14:46:19| 0.5| 0.0|ERROR |Error executing SQL command ('declare public_CensusTracts_crsr____ cursor for select "STATEFP00","COUNTYFP00","TRACTCE00","CTIDFP00","NAME00","NAMELSAD00","MTFCC00","FUNCSTAT00", AsEWKB("geom") as "geom" from "public"."CensusTracts" where TRACTCE00=001811'): 'ERROR: column "tractce00" does not exist LINE 1: ...om") as "geom" from "public"."CensusTracts" where TRACTCE00=... To clarify: the column in my database is called TRACTCE00, and the error message seems to indicate it doesn't e
I was curious if the behavior of published parameters from custom transformers changed in FME 2013, but I couldn't find the answer yet. Maybe someone can tell? In his 'FME Evangelist' blog, Mark Ireland once wrote the following: "Published parameters can be a little confusing too. Normally, once a parameter is published the end-user is prompted for a value at run-time. In custom transformers, this is a little different. When a parameter is published in a custom transformer, you can look at it as prompting the main workspace for a value; i.e. it appears on the parameters dialog for the custom transformer, but it doesn’t get used as a prompt at run-time. To prompt for a custom transformer value at run-time, you first create a published parameter within the custom transformer, then - back in the main canvas - locate that parameter in the Navigator window and publish it again." For as long as I can recall, this is always how it worked and I never liked
I have some polygons (fields) and each has a primary key ID. I also have some attributes (land owners) stored elsewhere, with a matching ID. The relationship is 1 Polygon (field) to Many attributes (owners). This is because each plot of land can have potentially more than one person who has a stake in the ownership of that plot of land! The solution I'm looking for is the most efficient way of cloning my fields when there is > 1 owner. So if 1 field has 3 stake holders, I want to clone the geometry 3 times and have each owners details tagged to an identical polygon. I can happily build a list at the moment by joining my two flows of data (fields and attributes) using the FeatureMerger but I can't then see an elegant way of cloning the polygons, short of counting the number of group elements and then Cloning and Indexing with lots of duplicated Transformers. Does anyone out there have any bright idea's that I'm missing? It's got to the stage where I have snow b
Hi, I'm facing an issue when using a published paramater which is in cyrillic. When i set the published paramater manually in the workbench and it is properly fetched and written at the ouput. (I'm using version 2013) When I try running the workbench from command line (defining the parameter directly in batch file and also tried to use it within parameter file) the parameter is badly encoded at the ouput. I tried to search on this topic, so I tried the set the code page as 1251 in the batchfile but with no success. Do you have any idea if this is dos/windows issue or an FME issue and is anyone able to use published parameters in cyrillic (or other language with special chars)? Thanks for the tips. Zdenka
Hi Folks, I am new to the FME Desktop. I would like to ask if there is a way to export / generate the script after I have defined the detail of my translation in workbench? For instance, the script of the parameter, reader & writer configuration and the transformer used. Is there any method to achieve this? If yes, then I can customize it based on the generated sample script. Thanks in advance for your advices.
Hi All, I have a FME Workbench which runs every night via a scheduled Windows process which looks at a MapInfo TAB file which has been edited during that day by users. It QAs the data and then spits out the "good" elements to a Production area for use by the orginisation the following day. This workbench works fine. We can run it manually and the process executes perfectly. The problem is that over the past few nights the process has failed to execute because it fails to read the TAB from the editing directory. We have checked the system logs and it seems that (different) users have left their computers on overnight with the file open... My question is (finally) can FME execute any "system" commands? We obviously want to kick any users off who have a lock on these files and I just wanted to know if we can write it into the workbench. There is some talk in the office here about using some Python to do it, but I have only dabbled in it and am not really sure
I have a workspace that writes out an excel file using a dynamic writer, to which I have added some user attributes. The output puts the user attributes at the end of the dynamic schema attributes, ie, in the last columns of each excel worksheet. Is there a way to control the order of these field using a dynamic writer?
Dear All, I have made some ascii grids in different software packages. I used a lambert confomal conical projection, with de WGS84 as coordinate system. The three software packages used different elipsoid parameters: Global Mapper: Semimajor Axis: 6378137.0; Semiminor Axis: 6356752.314245 ESRI: Semimajor Axis: 6378137.0; Semiminor Axis: 6356752.314245179 FME: Semimajor Axis: 6378137.0; Semiminor Axis: 6356752.3142 Can anyone explain me the consequences of these differences? The grids can be 1000 km in length. And maybe somebody also knows why the software packages have used these different parameters? Hope you can clarify. Kind regards, Guido
Does the new Blue Marble intergation allow for Horizontal Time Dependent Positioning (HTDP) reprojections? The blue marble software does allow for this type of transformation and I want to know if FME can take advantage of this if I have Blue Marble installed.
Here's my workflow scenario: 1. Vendor uploads multiple county parcels into FTP server - file is submited by county 2. Running on a scheduled task, FME unpacks and downloads each county parcel 3. Each zip file is unpacked and stored in a shared folder with county sub folders. 4. New feature classes are added in either in SDE or FGDB 5. Feature classes are added to an existing MXD using a layer file template 6. MXD is saved as MSD (perhaps overwrite an existing one) 7. MSD is then updated into ArcGIS server as a web mapping service County parcels are in FGDB and SHP. Only the FCs in the FGDB will be merged into a single store for all county FCs delivered. New deliverables are received weekly and updated quarterly. I'm thinking of using Python in FME for the functionalities that will translate the MXD, MSD, and layer files. This involves almost 160 county parcels and 4M records that's why it would be good to automate this workflow.
Hi! When using a workspacerunner on a workspace it will go through the FAILED port if it fails and the SUCCESS port if it succeedes. However what if I have a situation where I want it to write to an output - BUT under certain conditions I also want it to FAIL AFTER writing the file. Can I set the attribute SUCCESS or FAIL on a python-shutdown script, if yes, what is the name of the parameter?
Hello, I notice that FME Server displays in the Repositories TAb the Workbench Title and Description etc, is there a way to get these attributes to use in a Python script within the Workbench? I want to email via FME Server Notifier that the workbench 'its name' is failed or succeeded. Cheers,
Hi, I am creating a data download service with FME Server that should provide an ESRI File Geodatabase and an MXD file. The MXD file should be postprocessed with Python and arcpy in a shutdown script to fit the feature classes, extent and projection of the extracted data. The workspace transfer the MXD is to the FME Server output location together with the File Geodatabase. This works well in FME Desktop. The MXD is accessed programatically using an output folder published as a parameter. The same method does not work with FME Server. How do I access the MXD file in the FME Server output location programatically from Python? Regards, Knut Olav
Apologies if this has been asked before, I have tried searching Google/FMEPedia for it, with no luck. I'm having trouble getting the "request" string in our emails sent from FME Server 2012. Our previous FME Server 2010 emails - used the variable %request% - however I'm having no luck using } Below is what I have for our current "success" template: <fmeblock>Your FME translation (job ID {id}) has succeeded. Click on the link below to download the result:&#10;&#10;{urlPrefix}{ResultRootDir}/{@getFileName(@zip(OutputLocation))}&#10;&#10;</fmeblock><fmeblock>INFO: FME Request Parameters&#10;&#10; : This download file will only be available for 7 days, then it will be deleted.&#10;&#10;</fmeblock> <fmeblock>Time Started: {timeStarted} &#10;&#10;Time Finished: {timeFinished}</fmeblock> Which results in this: Your FME translation (job ID 306) has succeeded. Click on the link
Hi, I want to create a point for each species row 11, need create 3 points with the column name as an attribute NB the source data has approx 50 columns OBJECTID * SHAPE * WPT East North Date Azolla_filiculoides Blechnum_minus Carex_breviculmis Carex_geminata Carex_maorica Carex_ressectans Carex_secta Carmichaelia_corrugata Centella_uniflora Cheilanthes_sieberi Cordyline_australis Crassula_colligata_subsp_colligata Dichondra_repens 1 Point 26 2461536 5747297 4/12/2012 2 Point 27 2461489 5747326 4/12/2012 x x 3 Point 28 2461468 5747298 4/12/2012 x 4 Point 29 2461491 5747229 4/12/2012
Hi, I'm trying to connect to a database using the ODBC 3.x data reader. The parameters seem correct and I can see the tables in the Table list. When I try to add the data I get the error: ODBC2 Reader: Now reading schema for gistxtaxes Database Generated Error Information: Database Error Message: [DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OPENEDGE]Table/View/Synonym not found (7519) Database SQL Statement Text: SELECT * FROM "gistxtaxes" WHERE 1=0 SQL State: 42S02 Variable Information: ODBC2 Reader: Failed to get schema for feature type 'gistxtaxes'. Continuing with next feature type in the list I can connect to the data base and add data in ArcMap using the same connection parameters. Any idea what's going on?
We have two default subscriptions on FME Server which are email tasks that occur on success or failure of a workspace: EmailJob_Success & EmailJob_Failure. Can these be assigned to specific repositories? What if you have two download portals on the same FME Server, can they have different e-mail templates assigned?
What does it mean when a writer is dynamic and what are the dynamic schema settings doing? Thank you to anyone can help.
I was wondering I do a lot of ad hoc workbenches to various databases and geodatabases. Is it currently possible (if not I would like to suggest it as an improvement) save the conection properities for teh databases I frequently. This would be a huge time saver and save on problems with typos.
How do I change/or add a Palette Name of a raster?
Hello Im trying to View my stored data on Oracle with FME Universal Viewer 32 bits. I have installed Oracle_Client 11g 32 bits on my PC. Also I have Win 7 64 bits When Im Trying to did it, it sent this message: Error connecting to Oracle database: message was `ORA-01017: invalid username/password; logon denied'. (serverType=`ORACLE8i', serverName=`orcl', userName=`itu', password=`***', dbname=`') Failed to open database with username='itu', retrying using uppercase username Environment variable ORACLE_HOME is not set.
Is there a known issue concerning FME (in my case 2011SP4 and 2012SP3 aswell) about not being able to truncate Oracle base, stating: Truncating table `EESTITOPO.HYB_VOOLUVEED_75T_J'... Failed to truncate table `EESTITOPO.HYB_VOOLUVEED_75T_J'. Table may not exist However, when truncate is defined in the "SQL To Execute Before Translation" under advanced writer properties, then truncate operation succeeds. Thank you, Raivo Alla Estonian Land Board
??Windows?????????: fme.exe wb-xlate-1353554731187_5952 --SourceDataset_MapGis6x """""C:\\Documents and Settings\\Administrator\\My Documents\\1.WT"" ""C:\\Documents and Settings\\Administrator\\My Documents\\1.WP""""" --DestDataset_MapGis6x "C:\\Documents and Settings\\Administrator\\My Documents" ???? ... Feature Manipulation Engine 2012 SP2 (20120417 - Build 12238 - WIN32) FME_HOME is 'C:\\Program Files\\FME\\' FME Desktop Professional Edition (floating) Permanent License. Machine host name is: fangjun START - ProcessID: 904, peak process memory usage: 26024 kB, current process memory usage: 26020 kB FME Configuration: Command line arguments are `C:\\Program Files\\FME\\fme.exe' `C:\\DOCUME~1\\ADMINI~1\\LOCALS~1\\Temp\\wb-xlate-1353554731187_5952' `LOG_STANDARDOUT' `YES' `LogCount' `C:\\DOCUME~1\\ADMINI~
Hi, is there any way we can bring in an input file based on today's date? For example, if we save a file from a database every day, and today's file is called "20121114_Switch_Data.xlsx" can we have a default input (reader) to prepend today's date and grab the latest file?
Hi, I'm trying to debug a workbench and was and was wondering if it's possible to see the flow of one particular record. About 85k records (all with a unique ID) go into the workbench and flow through a network of transformers before all coming out via a single writer. I have identified several features that have been processed incorrectly but in order to work out what went wrong I need to work out the path they took through the transformers. Any suggestions on how to achieve this? Thanks