Solved

FeatureReader crashes on reading ArcGIS Pro filegeodatabase

  • 25 March 2024
  • 5 replies
  • 79 views

Badge +1

Hello,

as it says in the title: FeatureReader crashes on reading ArcGIS Pro filegeodatabase.

 

For my work I built a workbench were previously data got written to an Arcmap *.gdb which worked flawless. But now since my company is switching to ArcGIS Pro, I'm had to update the *.gdb to the ArcGIS Pro standards to be able to work with annotations. After running it with that updated *.gdb I received errors. After some fiddling it seemed that the issue was resolved. But a few runs later I found out that there were some attributes that I had to alter to the *.gdb to streamline it for later production steps. No probs so far. After doing that, the FeatureReader i use came up with the old attributes, and not the newly inserted. So I thought, I'll repoint it to the *.gdb, after doing so, the workbench crashed…

I've tried different things to find out where the problem lies: Maybe a feature had bad geometry? Maybe to many features? Maybe the *.gdb was corrupted? But nothing I did helped. As a last step I tried to create a new *.gdb in ArcGIS Pro and than try to load it with the FeatureReader… Also instant crash. Oh yeah, the created *.gdb was empty. 

 

Log file shows nothing abnormal, the workbench crashes before it can write something.

The versions of software used are:

FME: FME(R) 2022.2.0.0 (20221103 - Build 22765 - WIN64) (and using FME python 3.10+)

ArcGIS Pro: ArcGIS Pro 3.1.2

icon

Best answer by stalknecht 3 April 2024, 13:54

View original

5 replies

Badge +1

I became aware of the workspace parameter Esri ArcGIS Compatibility setting in the Navigator where you can choose between auto/ESRI Arcmap/ESRI ArcGIS PRO, but unfortunately either setting won't fix the crashing.

Userlevel 2
Badge +13

Hello @cfdune, thanks for posting and sorry for not reaching out sooner. This doesn’t sound quite right, and I wouldn’t expect this process to cause a crash. Are you able to submit a support case with us, so we can take a closer look at the issue? Happy to help, Kailin. 

Badge +1

At my company we work in VDI's and our department has several slightly different VDI's for different jobs. A fellow worker tried it on another VDI than our usual VDI and there it seems to work. So it is probably something underwater what causes this.

 

Userlevel 1
Badge +18

Please update to a more recent version of FME. It should be FME 2023.2 or higher. See the notes on FME and Esri versions:

https://support.safe.com/s/article/notes-on-fme-and-esri-versions-and-compatibility

Badge +1

After extensive searching, this reaction sums it all up.

Please update to a more recent version of FME. It should be FME 2023.2 or higher. See the notes on FME and Esri versions:

https://support.safe.com/s/article/notes-on-fme-and-esri-versions-and-compatibility

 

The difficulty at my company was that our IT department upgraded ArcGIS Pro to a higher version, but didn't install the compatible version of FME next to it on my primary VDI. And like I said earlier, we work with different VDI's, so that makes it a little bit more complex to update, because of the different things we do here, we sometimes need newer or lower versions of software.  I was in luck that another department was running a lower version of FME with compatible ArcGIS Pro version.

IT has now scheduled to upgrade FME and ArcGIS Pro within a few weeks, and we are to test it first at a dev VDI.

 

@stalknecht You would know it, because you told me in person 😎

Reply