Solved

httpcaller add feature service attachment file not found?

  • 15 August 2023
  • 5 replies
  • 31 views

Badge +1

Anybody tell me what I'm getting wrong here? Document Link path is valid. No errors in the FME log but attachment not found in the http response?

httpcaller 

icon

Best answer by nielsgerrits 16 August 2023, 12:56

View original

5 replies

I think you have to set the correct MIME Type. It is a bit hidden. In the Multipart Upload, click in the Value field, then click on the ... button.

Badge +1

I think you have to set the correct MIME Type. It is a bit hidden. In the Multipart Upload, click in the Value field, then click on the ... button.

Thanks @nielsgerrits​ ,

 

After clicking Edit Parameters for the value column I've set mime to: image/bmp but attachment file not found error remains.

E.g. R:\\Libraries\\Images\\SE photos non spatial\\Gates\\stricklandgate10.bmp is a valid path in my DocumentLink field and returns an image but still returning the error.

Thanks @nielsgerrits​ ,

 

After clicking Edit Parameters for the value column I've set mime to: image/bmp but attachment file not found error remains.

E.g. R:\\Libraries\\Images\\SE photos non spatial\\Gates\\stricklandgate10.bmp is a valid path in my DocumentLink field and returns an image but still returning the error.

I do not have a working sample lying around for uploading attachments, but I have something similar (update thumbnail) and I put the token and the format in the multipart form upload, not in the query string parameters. Not sure if that is your problem, but it's worth a try?

Thanks @nielsgerrits​ ,

 

After clicking Edit Parameters for the value column I've set mime to: image/bmp but attachment file not found error remains.

E.g. R:\\Libraries\\Images\\SE photos non spatial\\Gates\\stricklandgate10.bmp is a valid path in my DocumentLink field and returns an image but still returning the error.

If I check the documentation, it expects a different input parameter? Not "fileobj" but "attachment"

Userlevel 1
Badge +11

I think you have to set the correct MIME Type. It is a bit hidden. In the Multipart Upload, click in the Value field, then click on the ... button.

 

 

 

Thanks @nielsgerrits.

I needed thumbnails to show in the pop up gallery of an AGOL web map, instead of a download link.  I was using the Arcade expressions workaround and not too happy with that.

The not so obvious mime-type parameter did it for me. 

I suggested an idea to improve the HTTPCaller and also address multiple mime-type attachments. Please upvote if you like  this idea.

 

Reply