Solved

Sluggish performance with comment field

  • 10 July 2024
  • 1 reply
  • 16 views

Badge +1

Hello, I am a first-time poster on the FME forum. My goal is to read data stored in a plain view from a non-spatial Oracle database and then write it to an Oracle SDE geo_dbtable. 

The issue is that my Oracle Non-Spatial Reader slows down, taking more than 30 minutes to execute the SQL Statement when I include two comment fields that are long, 2000 characters. When I run the same query in SQL Developer, the result is back in a few seconds.   

The log message that gets stuck on is:  ORACLE Reader: Executing SQL Statement `SELECT…<field names> to obtain features for feature type <Oracle View Name>

If I uncheck the comment fields in the User Attributes tab the reader returns quickly, within a minute.  So I’m skeptical that it is caused by network distance.  

Given these challenges, I need some guidance. I’ve tried using an Oracle NCLOB to hold the comments in the view, but the result remains sluggish. I'm eager to learn how to optimize my workbench's performance when dealing with large comment fields.   

I am using Data Interoperability FME(R) 2023.1.1.1 (20231011 - Build 23636 - WIN64)

Thanks, Josh

icon

Best answer by colejo02 11 July 2024, 14:14

View original

1 reply

Badge +1

Hello I figured out how to improve performance in my model.  I had several unneeded transformers, readers, and writers in the workflow. I disabled/deleted these and their connections and the model performance improved. The post below also provides suggestions on how to speed up Oracle readers.  

 

Reply