Question

Exporting the project is not permitted. This project contains items that don't exist or are inaccessible by you.

  • 16 May 2024
  • 6 replies
  • 62 views

Badge +13

I have set up a project in our test environment containing two workspaces in a repository, a workspace app and an automation. Workspaces use a resource\data subfolder. The automation writes data to a database through a database connection. All this is set up with my admin account.

When I try to export the project to move to our production environment I get the error: “Exporting the project is not permitted. This project contains items that don't exist or are inaccessible by you.”

In the project I have added the automation, connection, repository, resource path and workspace app, 5 items in total. I have verified that the resource\data path is migrateable as per the first note here: https://docs.safe.com/fme/html/FME-Flow/WebUI/Exporting-Importing-Projects.htm

Any tips on why I am not allowed to export? The items defined in the project all exists and as an admin I have access to all items...


6 replies

Badge +5

Commenting since we are experiencing the same issue

Userlevel 1
Badge +5

If you look at the project dependencies (3 dot icon), and click on the hyperlink for the database/resource connection, what is the URL that is displayed in the browser (you can just display the portion after [fmeflow]/fmeserver to protect your server URL). 

There was an issue previously whereby resource connections were not getting passed correctly in the URL.  This had been fixed, but the behaviour is similar.

 

Badge +13

I’m not quite sure where to look. If I open the project, the Resource Path has no dependencies:

 

If I open Resources > Data for the project area the URL is https://fme.tst.banenor.no/fmeserver/resources/browse?path=FME_SHAREDRESOURCE_DATA%2FLDB%2F

Userlevel 1
Badge +5

Thank you for confirming that.  It does look like the URL is resolving correctly, so I don’t believe this is the same issue we have had previously. 

You mentioned that there is a workspace app in the project - if you remove the workspace app, but keep everything else (including the resource connection) does the Project export correctly?

If so, there is a separate issue that we have filed (and fixed in 2024.0+) where workspace apps that have a resource connection are not exporting correctly as a project.  The workaround to this is to either run the workspace with the Job Submitter service first to ensure the resource path is created before creating the project.  Another option is to have the default path point to an existing data resource folder. 

If this does not work, if you can please submit a case for our team to dive into this deeper would be great!

Badge +13

I tried first to run the Workspace app with the job submitter service (it is set up with the data streming  service originally). The app runs ok. I then switched back to data streaming and the export still fails.

Secondly, I tried to remove the app from the project, but still get the same error on export.

Userlevel 1
Badge +5

Sorry that that didn’t work!  

If you can please submit a case at this point and be sure to include the following things, it will help our team dive into this deeper:

  • screenshot of the error message
  • screenshot of the components included in the project
  • the exact build version of FME Flow
  • if possible the workspace that you are using

Thank you!

Reply