Solved

FME Flow landing page stuck in refresh loop. Login not possible after reinstall.

  • 23 October 2023
  • 2 replies
  • 0 views

Badge

Hi community!

 

I installed FME Flow 2023.1.1.1 on Ubuntu 22.04 with installer [1]. I choose

setup type "Distributed / Fault Tolerant" to use an existing Postgres instance

according to [2]. I then set up the Postgres database according to [3].

I also changed proxyPort in /opt/fmeflow/Utilities/tomcat/conf/server.xml

to the correct port number. Then installed, enabled, and started the systemd

units according to [4].

 

Everything worked at this point and I could log in as admin and change the

password as required. I could also log out and log in as admin. I then

created a new admin user. When I logged out and try to log in as the new user

the landing page was stuck in an infinite refresh loop. I also deleted all

cookies which did not have any effect on the constant reloading.

 

The URL is https://view-db.vinci-energies.de/fmeserver/.

 

I uninstalled FME Flow, dropped the fmeserver database, and installed FME Flow

again as before. Now the landing page doesn't even prompt for the admin login

and instead looks like I'm already authenticated. But the menu for the user

settings does not open. I also checked the database connection and it works.

Also the GET requests for the following URLs now result in a connection reset.

 

https://view-db.vinci-energies.de/fmeserver/REST/token?cb=1698069629532

https://view-db.vinci-energies.de/fmeserver/REST/keepAlive?suppressBroadcastError=true&cb=1698069633532

 

A second reinstall did not have any effect and there's still no prompt for the

admin login.

 

Any ideas? I can also provide /opt/fmeflow/install.cfg and logs if necessary.

 

[1] https://downloads.safe.com/fme/2023/ubu_22/fme-flow-2023.1.1.1-b23636-linux-x64~ubuntu.22.04.run

[2] https://docs.safe.com/fme/html/FME-Flow/AdminGuide/Run_the_Installer_Linux.htm

[3] https://docs.safe.com/fme/html/FME-Flow/AdminGuide/Configure-FME-Flow-Database-on-Separate_Server-2-Tier.htm

[4] https://docs.safe.com/fme/html/FME-Flow/AdminGuide/Configuring-FME-Flow-As-System-Service.htm

 

--

Erik

icon

Best answer by ewie 3 November 2023, 00:38

View original

2 replies

Badge +5

Hello,

Would you be able to create a support case with the following information -

  • Tomcat and Core logs
  • How did you create the additional admin user- was it an imported user via SAML ? Or was it a system user ?
  • Did you try accessing the Web UI via the IP address instead of the FQDN and then try logging in? Does it still have the login looping behaviour?
  • When uninstalling please ensure this document was followed- https://docs.safe.com/fme/html/FME-Flow/AdminGuide/Uninstall.htm and especially removed the file share and install directories in all distributed hosts.
Badge

The problem was the cache of our reverse proxy which apparently prevented FME Flow frontend from seeing the logout. Disabling the cache solved the issue.

Reply