Solved

Is there a size limit on the payload of an Http request received by FMEServer/FMECloud?

  • 1 October 2020
  • 5 replies
  • 168 views

I have a workspace published on FMECloud which is triggered by http requests from an api. The request contains a geojson geometry defining an area of interest. With larger geometries I receive an error from FME saying the request payload is too large. Can someone tell me the size limit on request payloads and is it possible to configure it to a larger value?

icon

Best answer by david_r 1 October 2020, 09:30

View original

5 replies

Userlevel 6
Badge +32

I don't believe there is a size limit, there is definitely a time limit. Could it be reaching one of those?

 

Screenshot 2020-10-01 145437

Badge +2

Hi @Stuart Voerman​ 

I believe this limit will be set inside tomcat, which means that on FME Cloud you're unable to go in and edit the tomcat configurations. If you were managing an FME Server, you may have had success editing the tomcat configuration files.

Are you able to generalize the geometries that you're sending to FME Cloud so the payloads are smaller, or restrict users to a square/rectangular area of interest?

Thanks for the prompt replies on this.

The geometries we are sending are already buffered and generalized, we don't want to reduce them any further. After reviewing the cloudwatch logs for the service we found that the api is using a GET request to send the geometry along with other parameters. We are going to try updating this to a POST which should take a bigger payload.

Userlevel 5

Thanks for the prompt replies on this.

The geometries we are sending are already buffered and generalized, we don't want to reduce them any further. After reviewing the cloudwatch logs for the service we found that the api is using a GET request to send the geometry along with other parameters. We are going to try updating this to a POST which should take a bigger payload.

If this means that you're currently sending the JSON as a URL-encoded parameter with a GET, then you're likely hitting the URL length limitation, which is de-facto around 2000 characters. This is not specific to FME.

Sending the JSON by POST should go a long way to fix this.

Sending as a POST has solved the issue, thanks all for your input.

cheers.

Reply