Question

Error using AttributeFileWriter and FeatureReader on FMECloud - Unfinished file?

  • 3 February 2022
  • 3 replies
  • 13 views

Badge +1

I have a workbench which is writing out a zip file containing a shapefile using AttributeFileWriter then using a FeatureReader on the resulting zip file.

 

It works fine in FME Desktop 2021 writing to a temp directory. When I run on FMECloud using the Temp resource folder I get an error when reading the zip file. If I download the zip file from the resource folder the file is valid.

 

It's like the file is being held onto by the AttributeFileWriter (or it hasn't finished writing).

I don't get the two warnings below in FME Desktop. It seems to imply the files haven't finished being written out.

 

Is there any way to avoid this unfinished writing, or is there any way to take the binary shapefile zip data and read that directly without writing out to file?

It might be possible to break out the workbench into multiple workbenches in the automation.

 

imageimageThis might happen on FME Server as well as FMECloud (I haven't tried it yet)


3 replies

Userlevel 1
Badge +22

This shouldn't happen with a zip file. Either the zip is incomplete and corrupted or the Index is incomplete to begin with.

Try adding a Decelerator between AttributeFileWriter and FeatureReader to test if I/O time is at fault.

Userlevel 5
Badge +32

As noted above, the Decelerator might help - another transformer to try is the FeatureHolder.

Badge +1

In the end I didn't resolve, but I parsed the workbench into two workbenches in the automation with an automation writer to pass file name. Works a treat and more interesting to run (love the automations!)

Reply