Question

Intermittent issues connecting to Oracle SDE

  • 18 December 2023
  • 1 reply
  • 10 views

Badge +6

Hi we have FME Server 2021.3, ArcGIS Pro 2.9 installed [concurrent license - license manager on separate machine]

connecting to ArcGIS Enterprise Geodatabase 10.9.1

on Oracle database 21c

We have a few automations running at different schedules. We have seen intermittent issues while connecting to read/write to the geodatabase.

 

1) Error while retrieving an ArcObjects update cursor for the table/feature class 'xxx'. The error number from ArcObjects is: '-2147155559'. The error message from ArcObjects is: {Failure to access the DBMS server [ORA-03114: not connected to ORACLE] [xxx]}

 

2) Could not open the Enterprise Geodatabase because the local version of ArcGIS is not compatible with the server's SDE version.

 

The above 2 issues causes automation to fail

 

Also, the following error occurs consistently for each run, but the automation carries on successfully:

3) BADNEWS: Execution of statement `SELECT SDO_VERSION FROM DUAL' did not succeed; error was `ORA-00904: "SDO_VERSION": invalid identifier'. (serverType=`ORACLE8i', serverName=`xxx', userName=`xxx', password=`***', dbname=`')

 

Any ideas how we can prevent above errors. I have tried to add retry for 3 times after 1mins, but we still get the failures.

 

 


1 reply

Badge +5

Hello,

Please ensure that ArcGIS Server is installed and licensed on the same machine as the FME Server Engine Service. The ArcGIS version must be compatible with FME: Notes on FME and Esri Versions and Compatibility.

 

Do you see any patterns in terms of which workspaces show that error on your system? Is it always the same one or will it happen at random with any workspace that connects to SDE?

 

Also, do you see any patterns in terms of when the errors happen? Is it possible that there could be system maintenance tasks happening that might affect the SDE that you are connecting to or the network itself?

 

Would you be able to create a support case and send us a successful and a failed job log?

 

Regarding the last error that does not affect translation- do you also see this error when running the same workspace in FME Desktop of the same version?

Reply