Solved

Why does Topic Monitoring not work in Mozilla Firefox? It works in Google Chrome!

  • 22 October 2016
  • 1 reply
  • 5 views

Userlevel 4
Badge +13

Why does Topic Monitoring work without error in Google Chrome, but when I try to enable it in Mozilla Firefox, it starts and immediately stops?

I have configured my FME Server installation to use a self-signed certificate, but I have already made the security exception for each web browser! What gives?

Note that the fmewebsocket.log doesn't contain any helpful information, it only lists the attempted starts and immediate stops:

Fri-21-Oct-2016 05:20:17 PM   INFORM   New I/O server boss #5   408506 : channelOpen => -1,008,910,118
Fri-21-Oct-2016 05:20:17 PM   INFORM   New I/O worker #1   408511 : Channel closed: -1,008,910,118
Fri-21-Oct-2016 05:20:23 PM   INFORM   New I/O server boss #5   408506 : channelOpen => -231,922,873
Fri-21-Oct-2016 05:20:23 PM   INFORM   New I/O worker #2   408511 : Channel closed: -231,922,873
Fri-21-Oct-2016 05:20:23 PM   INFORM   New I/O server boss #5   408506 : channelOpen => 2,132,443,954
Fri-21-Oct-2016 05:20:23 PM   INFORM   New I/O worker #3   408511 : Channel closed: 2,132,443,954
icon

Best answer by rylanatsafe 22 October 2016, 02:40

View original

1 reply

Badge +11

After you add the security exception for the untrusted certificate, e.g. forhttps://fmeserver.com:443/fmeserver -- you also need to add an exception for the Web Socket URL.

Navigate directly to https://fmeserver.com:7078/websocket (modifying as appropriate for your hostname), and confirm the security exception for this page.

Topic Monitoring should now work for Mozilla Firefox! This was tested with v49.0.1 of the web browser.

 

* If you are having issues with Internet Explorer, try unchecking 'Display intranet sites in Compatibility View' (Tools > Compatibility View settings). This was tested with v11.0.9600.18500 of the web browser.

Reply