Solved

Topic monitoring not working

  • 31 March 2016
  • 9 replies
  • 25 views

Userlevel 1
Badge +18

If I hit the Topic Monitoring Tab: The current status says Connecting.

After a few seconds the Current Status returned to stopped.

The status is never "Started"

Any advice to get the Topic Monitoring working?

icon

Best answer by mark2atsafe 8 April 2016, 17:39

View original

9 replies

Userlevel 5

Hi

Are you maybe accessing FME Server over https?

If so, have a look here: https://knowledge.safe.com/questions/5151/notifications-seems-to-work-but-the-topic-monitor.html

David

Userlevel 1
Badge +18

Hi

Are you maybe accessing FME Server over https?

If so, have a look here: https://knowledge.safe.com/questions/5151/notifications-seems-to-work-but-the-topic-monitor.html

David

Nope, it's http

Userlevel 2
Badge +12

Are you using ARR in IIS? Does topic monitoring work when you login onto the server and try it there?

Userlevel 5
Badge +30

The only thing I can think of is this from the help documents:

Note: Topic monitoring uses the WebSocket communication protocol, which occurs over port 7078. If necessary, be sure to configure any firewall settings to allow for open communication on port 7078.
Userlevel 1
Badge +18

Are you using ARR in IIS? Does topic monitoring work when you login onto the server and try it there?

No it's the default TomCat. I will ask our customer to try it from the fme server localy.

Userlevel 1
Badge +18

The only thing I can think of is this from the help documents:

Note: Topic monitoring uses the WebSocket communication protocol, which occurs over port 7078. If necessary, be sure to configure any firewall settings to allow for open communication on port 7078.

I will ask our customer to try it from the fme server localy.

Userlevel 1
Badge +18

The only thing I can think of is this from the help documents:

Note: Topic monitoring uses the WebSocket communication protocol, which occurs over port 7078. If necessary, be sure to configure any firewall settings to allow for open communication on port 7078.

Thanks, we made an exception in the Firewall.

Badge +1

The only thing I can think of is this from the help documents:

Note: Topic monitoring uses the WebSocket communication protocol, which occurs over port 7078. If necessary, be sure to configure any firewall settings to allow for open communication on port 7078.
@Mark2AtSafe Any idea on why this would be happening in a Linux RHEL environment with no firewalls? I am having the same issue described here.

 

Userlevel 5
Badge +30
@Mark2AtSafe Any idea on why this would be happening in a Linux RHEL environment with no firewalls? I am having the same issue described here.

 

Hi @lopes8

 

I can think of a couple of things. One would be another application locking up the ports. Do you have anything else running that might be interfering with port 7078? Also, is the rest of Server working correctly? Is it using a non-standard port other than 80 or 8080? Is there a log file that has an error message in it to help us diagnose the problem? Also perhaps worth a check to see if the firewall is somehow running (sorry, I have to ask)! I found this info:

 

 

You can see if the firewall on Linux is running by using the command:

 

iptables -L -n

 

...as the root user. If you see any rules displayed, then the firewall is running. To turn it off temporarily, use the command:

 

service iptables stop

 

...as the root user. To turn it on again:

 

service iptables start

 

 

Hope this helps. If not then perhaps create a new question or file a case with our support team (safe.com/support)

 

 

Mark

 

Reply