Solved

WebSockets for FME Server (cloud), WebSocketSender: Failed to perform handshake with remote host

  • 29 September 2017
  • 2 replies
  • 20 views

Badge

hey folks,

https://fmeserver-eval-safe-software.fmecloud.com

when attempting to send sockets to the FME Cloud eval, it will continually fail for local host on port 7078, which makes sense, cause I am using the trail version on the cloud, anyways does anyone know of a way to connect to the sockets through FME cloud?

Thanks,

Doug

icon

Best answer by gerhardatsafe 2 October 2017, 17:48

View original

2 replies

Userlevel 5
Badge +32

Hi @dfresh,

This is a great question about FME Cloud.

Unfortunately i dont have on this time access to FME Cloud to test. Can someone help?

Thanks,

Danilo

Badge

Hi @dfresh

For 2017+ FME Cloud instances, port 7078 is closed by default and the WebSocket is accessed via the secure WebSockets protocol wss:// on port 443, since we use NGINX as a reverse proxy. NGINX allows connections to be proxied to the right service based on the request path. We took advantage of this and enabled WebSocket connections on port 443 (default HTTPS port). For more details check out this blog.

For the FME Server Evaluation instance, for example, the correct WebSocket Server URL to use is this:

wss://fmeserver-eval-safe-software.fmecloud.com/websocket

Please let us know if this works for you!

Reply