Solved

Uploading Google Sheets package to FME Flow

  • 10 March 2024
  • 1 reply
  • 37 views

Badge +5

Hi,

 

We’ve recently upgraded our FME Flow install from 2022.2 to 2023.2.1

I had a published workspace that used the Google Sheets v4 package. Previously when I published this workspace, the included Google Sheets package uploaded to FME Flow and became available to use in FME Flow. This all seemed to work fine.

Since the upgrade to 2023.2.1 I seem to be having trouble getting this to work. When I publish the workspace, using FME Form 2023.2, I get the option to upload the Google Sheets package, and this appears to work fine.

But when I run the workspace from FME Flow I keep getting this error:

File D:\Program Files\FMEFlow\Server\fme\metafile\SAFE.GOOGLE-SHEETS.GOOGLESHEETS4.fmf could not be opened

If I look in the Resources>Engine folder I can see that the file safe.google-sheets-3.3.4.fpkg has been copied in here (with the appropriate timestamp when I published the workspace).

Is there something else that has to happen to make this package available?

Thanks

Keith

icon

Best answer by keithhastings 8 April 2024, 23:21

View original

1 reply

Badge +5

Just answering my own question.

It appears that it is necessary for you to publish the google sheet reader/writer inside a workspace (.fmw) and then run the published workspace in FME Flow for it to install properly.

In my situation I had a custom transformer that contained the google sheet reader/writer. Publishing this custom transformer is not sufficient to install the google sheet reader/writer.

I then created a dummy workspace that contained the google sheet reader/writer and published this. This was still not sufficient. My workspaces that contained the custom transformer that contained the google sheet reader/writer still could not connect with google sheets.

It was only when I actually ran the dummy workspace in FME Flow that I then could get the workflow to work correctly.

Reply