Solved

Datastream HTML via HTTP Get Request

  • 24 June 2024
  • 5 replies
  • 51 views

Badge +1

Hello everyone

 

Im playing around with FME FLOW and uploaded my workspace. The workspace is running well with several parameters and writing me an OBJ file into my ressources and finally writing an HTML file (which opens a 3dviewer which opens the OBJ file).

When im running the workspace in FME FLOW i choose datastreaming Service, and after success it opens the HTML file in my Browser.

When i create a WebApp it is also running well and in the end opening the HTML file and showing the OBJ in the 3DViewer.

But since the WebApp is quite limited with layout etc. i created an easy HTML Website on my Server. Here i added a send request with the webhook url of that workspace and the get method.

And actually it is running, but after success its giving me a link to download a zip with the HTML and OBJ file.

To me it seems because im using the Get method, it is just putting all the results into that zip to download. I tried a bit around and also searched in forum but didnt find an answer.

Am i missing smth?

Would be glad if someone has an idea.

 

 

icon

Best answer by gisplan 25 June 2024, 23:56

View original

5 replies

Userlevel 2
Badge +7

Hello gisplan,

 

In the configuration of the webhook, whch service is enabled? It sounds like it’s the download service, when it should be the data streaming service. 

In the FME Flow interface, click on the User Settings icon (top right corner), then select Manage Tokens.

Find the token for your webhook, and click on it. Scroll down to Services, and expand that section by clicng on the down arrow on the right. Data Streaming should be selected, at least, that’s the one that works for me.

 

HTH,

Stefan

Badge +1

Hello Stefan

Thanx for the reply! i tried different ways, and yes the data streaming works, but it only gives me a zip file with a download link (and all written files, and not only the HTML file, which i chose under the your mentioned datastreaming Service).

Here i found that multiple files will be zipped, but since i chose only the HTML to stream, i am a bit confused, but i will try again later.

If that doesnt work i may try to trigger workspace without streaming data. Once it saved the obj in the ressources and give my website a success info, let website open the file directly within the 3dviewer.

Userlevel 2
Badge +7

As far as I know, in this case, you can’t write any other output - because that will cause the creation of the zipfile. You can only have the html output enabled, I think.

Badge +1

Ok i tried a bit around and no matter what Service i chose and no matter how many files were written, after success it always gave me the link to download a zip, also when i wrote the html only.

So with GET method in http seemed not to be the solution. After a beer i came to an way easier solution. I just change my website to open the Webhook query string with the disired parameters in an iframe. This way the Datastreaming Service triggered and after success it opened the HTML only with showing the model that was written in my temp ressources folder and coild be accessed with Token.

Still thanks for the effords!

Badge +1

Ok, i tried a bit around by changing Services and disabling writers and it always sent me a zip file. So it seems wirh the GET method, no matter what, it zippes the files and sends a download link.

The solution was to take the webhook url, fill it with my parameters and open it directly in the iframe. With datastreaming Service activated on the HTML writer it opened the also written obj file in the 3dviewer after successful job.

Thank you for your effords. 

Reply