Question

ArcGIS Pro Data Interop Write to ArcGIS Online Geodatabase won't delete

  • 5 March 2024
  • 6 replies
  • 112 views

Badge +6

I’m using Pro 3.2 and Data Interop extension with a simple workspace to pull point features from a SQL server database and publish them as a layer in AGOL, all within AWS on an ec2 instance. I have this scheduled to run every 15 minutes so users get fresh data. The workspace also uses an HTTP call to make the layer editable just before overwriting it, and then a second one after writing, to disable editing, because the layer is public. 

Seemingly intermittently, the file geodatabase used to publish the layer will not get deleted. I have the fgdb that was originally used to publish the layer still there in the same folder as the layer, but every so often another fgdb will be created and left in that folder too, so I get duplicates. Some mornings I check and there are 3-5 or more of them. I can manually delete them, but I’m trying to determine why they’re not getting deleted in the first place. I’ve checked the logs and can’t see anything out of the ordinary. 

I tried adding a 30-second Decelerator after the feature writer writes the data to AGOL, and before the final HTTP call that disables editing again, because I thought that maybe the writing operation was getting interrupted, but that didn't help.


6 replies

Userlevel 1
Badge +6

Hi @jfisch25. Sorry that you’ve been having challenges with your workflow.

From my understanding, your goal is to publish a layer to the same fgdb without creating duplicates of the fgdb.

My suggestion is to overwrite the existing file geodatabase when adding the layer before disabling edits to the folder. There is a similar, in context, question about overwriting layers in AGOL using the Esri ArcGIS Portal Feature Service Writer.

Hope this helps!

Badge +6

Hi @AliAtSafe,

Thanks for getting back to me!  Yes, I am trying to overwrite a hosted feature layer in ArcGIS Online that is published from a file geodatabase, without getting duplicate copies of the file geodatabase. 

I looked at the link you sent, and am familiar with using the “Truncate Existing” option for data, but in this case, I’m using the newer “Overwrite” option in FME Form 2023, which as I understand it, performs better since it eliminates the need to send delete requests to the layer to delete all features before writing new ones, as the “Truncate Existing” option does.  My layer has upwards of 60,000 features, and it needs to be updated multiple times an hour.

 

Userlevel 1
Badge +6

Hi, @jfisch25.

Thanks for confirming.

We tried to quickly reproduce the issue and would like to request more information to delve deeper. If your comfortable, could you share your workspace and your logfile here? If not, you can open a support case refencing this post and give an overview of what is happening with your workflow along with the workspace and log file attached there.

Thanks!

Badge +8

Hi @jfisch25 
Just wondering if you can share you log files. I ran the translation locally and was able to successfully run the workspace 5 times with deleting the published data 5 times as well. 

Look at line 421,  900, 1378, 1873 and 2351 in the attached log file. 
 

ArcGIS Online Feature Service Writer: Deleting Item 'TOTEMM_TTC_SOLAR_WIND'

 

Badge +6

Hi @rahulsharma,

Thanks for responding. I’m a little hesitant to share the entire log file, but I can see that it does explicitly say that it’s deleting the item.

 

 

Badge +8

Hi @jfisch25 

Can you file support ticket and share the log and workspace if possible? 
I have encounter another customer reporting a similar issue, its possible that we need to try few different scenarios. 
I can try to set up a schedule workspace to verify if this could be related to running from command line vs interactive (typically it should not be any different). 

 

Rahul 

Reply