Solved

Counter does not start at chosen value (FME 2020.0.0.1 build 20202

  • 17 August 2020
  • 6 replies
  • 76 views

Userlevel 1
Badge +7

I am having a problem with the counter transformer in multiple workbenches on multiple machines: It ofthen does not start at the set value (ussually 0 or 1). For instance; The counter in the image is set to start at 0. However: When I run the workbench it starts at 577. I have no clue at al why it does that.

 

counter

 

When I use featurecaching and I run the whole workbench one by one transformer it will start at 0. But ONLY when I manually start every single transformer before the counter.

 

I have this on this machine and another computer in completely different workbenches.

 

I use the counter to merge features. the workbench stops because it can not merge features based on wrong counts.

 

 

icon

Best answer by ebygomm 17 August 2020, 17:24

View original

6 replies

Userlevel 2
Badge +21

Do you have the Count Scope set to Global or Local?

Userlevel 1
Badge +7

it is set to global (standard settings)

Userlevel 2
Badge +21

it is set to global (standard settings)

In which case you probably want it set to Local

"Specify whether the scope of this counter is Global (throughout the entire workspace) or Local (for this transformer only). Global counters with the same Counter Name will share the same counting sequence, while Local counters will each have a unique counting sequence."

Userlevel 1
Badge +7

In which case you probably want it set to Local

"Specify whether the scope of this counter is Global (throughout the entire workspace) or Local (for this transformer only). Global counters with the same Counter Name will share the same counting sequence, while Local counters will each have a unique counting sequence."

I'll try and will let you know. Thank you!

Badge +2

Hello, I am experiencing the same problems with the counter transformer as michiedem.

The transformer is set to the default settings, but I want it to start with number 1.

However, when the workflow runs for the first time, it starts completely somewhere else.

And when I start the counter transformer myself, it does start with 1.

Does anyone have any idea? It doesn't matter whether I set the counter to local or global.

 

 

Userlevel 3
Badge +11

Hi, @jan-henk.

I tested out your scenario and found that local works on the first run after closing and re-opening the workspace. I’ll look into it and get back to you.

Reply