Question

FeatureWriter trying to add a suffix on table name (surface or polygon) in FME Form 2024.0.2.1


Badge +6

I am trying to write polygon features into a Esri Geodatabase writer where the layer name is NV_NATURRESERVAT. But, the writer is trying to add a suffix “surface” so the output name will instead be NV_NATURRESERVAT_surface. This is not correct.

First of all I dont want the a layer with a name like that. And second, before it reaches the writer the script filters out if theres a need to create a layer or not in Esri Geodatabase.

If theres a need to create a layer it will create on in another writer. If there exist a layer with that name the flow will continue to the second writer. In this case the layer exist, I just want to update it with new data. So, up until writer(s) the layer name is set to NV_NATURRESERVAT. But when it reches the writer it gives me error messages saying that no such layer exist:

“Esri Geodatabase Writer: Feature Class or Table 'NV_NATURRESERVAT_surface' must exist when Table Handling is set to 'Use Existing'
GEODATABASE_SDE writer: An error has occurred. Check the logfile above for details
PythonFactory output feature was rejected downstream. Check the logfile above for details
An error has occurred. Check the logfile above for details
Python Exception <FMEException>: FMEException: 1: An error has occurred. Check the logfile above for details
Error encountered while calling method `input'
Dataladdning_PythonCaller_5 (PythonFactory): PythonFactory failed to process feature”

This is why I believe that the featurewriter is adding the suffix but I cannot see where it is adding the suffix. I havent changed anything. Is this a bug?

Background: I had to update FME Flow to version  2024.0.2.1 at our company because of Arcgisserver update. Before this upgrade we worked with FME Server 2022.1 and I had no problem with that. After the upgrade when I tried to run this workspace I received this error. The point and line layer runs perfect without any weird addition of suffix on the layer name. 

Version: ME(R) 2024.0.2.1 (20240513 - Build 24217 - WIN64)

 


3 replies

Userlevel 3
Badge +11

Hi @souryana 

 

Thanks for reporting this error, it definitely seems suspicious. However, I think we need to investigate this further and try to reproduce it.

 

It might be worthwhile to contact FME Customer Support or the vendor you have purchased FME from regarding this issue.  

 

Please provide your workspace template with feature caching, as it would be helpful to track the ign_destination_layername. Please also send over your log file and include the version of FME Form you are using.

 

Also, if you are using an older version of FME Form, consider upgrading to 2024 and try to publish again to see if that works.

 

Crystal 

Badge +6

Hi!

Sorry for late reply and thanks for your quick answer. This script belongs to the company and I cannot share it on forums unfortunaltely but we have submitted it to our FME Customer Support and hopefully we will get an answer soon. 

 

Regards

Userlevel 1
Badge +7

Hej Souryana! Check the schema feature, I think you might have read from a source that allows different kinds of geometries in one featuretype. Look at the schema feature - if you check there you likely have a list fme_geometry{} that has multiple values.

Since an ESRI geodatabase only allows one type of geometry in each featureclass and you have the writer set to get the geometry from the schema feature, it handles it this way on the first feature to write (since there could be features with different geometries ending up at the FeatureWriter later).

You will need to read the schema from another source, cleanup the fme_geometry in the schema or use a SchemaScanner.

Hugo (from the dt team in NetView)

Reply