Question

Mixed Success Connecting to Floating License Server

  • 8 April 2022
  • 2 replies
  • 33 views

Badge +6

I know there is a lot of content covering this topic already, so I'll preface this by saying I have looked through it. I looked at the floating license server troubleshooting article here and the article about serving both ArcGIS and Safe licenses here and I have run the diagnostic .bat file. My issue is this: I can connect to the floating license server without issue, but one colleague can't connect at all, and another one can connect intermittently but always seems to encounter a similar issue to the one who can't connect at all.

 

SETUP

ec2 instance in AWS behind a network load balancer, with both ArcGIS License Manager 2021.1 and Flexera 11.16.2 installed. The license files for both are stored in the "License" folder for ArcGIS, and each license file specifies a unique port to use (ArcGIS Vendor: 27009, Safe Vendor: 27002). Instance firewall has ports 27000-27009 open and security group settings allowing traffic on those ports from our specific office IP's. The load balancer has listeners on ports 8080 and 27002 and healthy target groups.

 

PROBLEM

I can access a license consistently by supplying the network load balancer URL, and either not appending a port at all, or by appending either ":8080" or ":27002" at the end. I can do this from my personal computer as well as from another ec2 instance in our AWS environment. I have also tested connecting on a separate computer in my office, and I can successfully access it from there too. My colleague, who is in a separate office in a different part of the country, cannot access a license using any of those 3 options and gets the same error:

 

fme_license_error 

TROUBLESHOOTING (based on the troubleshooting article referenced above)

  1. I have run the Troubleshooting Report, but don't see any major red flags.
  2. The license file is NOT in the Flexera folder, but in the License folder for ArcGIS, since I'm using that software to serve the licenses. (The safe vendor daemon is also in the "bin" folder in the ArcGIS License Manager install location so it can find it successfully).
  3. I believe I'm running the most recent version of the license manager, but the licenses are being served by ArcGIS I believe. I'm a little unclear on how the two work together.
  4. Hostname and hostid are still valid I believe, since I can still access licenses.
  5. Have not renamed the safe.lic file.
  6. Have not tried restarting, mostly because both ArcGIS and Safe licenses are recognized when I do a status inquiry so I know they're being read. And again, I can access a license just fine.

 

Connection issues Troubleshooting

  1. Yes; ArcGIS and Safe are both being served out.
  2. Firewall rules have ports 27000-27009 open on the ec2 instance. I don't know for sure if my colleague's ports in that range are open on his computer. I have specified ports for both licenses on the server.
  3. There are not previous .dat files on his machine in any location.
  4. Telnet fails when I try it (it says it tries to connect on port 23). I think it also fails when he tries it, though I haven't confirmed.

 

If this was a server configuration problem, I'd assume none of us could access a license, but since I can, I don't understand what is preventing him from accessing one. Any advice would be appreciated, thanks!


2 replies

Userlevel 5
Badge +29

It sounds like networking issues. Can your other two colleagues reliably get Esri Licenses from the same server?

Badge +6

After lots of troubleshooting and a few calls with Customer Support, I think this has been resolved. The short version: I was trying to serve ArcGIS and FME licenses from the same folder with one service and through one port, which seems to have been the root cause. I'm still a little unclear because I was able to pull a license on my local machine no problem, but the resolution involved the following:

  1. Move the Safe.lic and Safe vendor daemon to the Flexnet installation folder and create a safe.log file in a new C:/Flexlm folder. I initially had placed them in the ArcGIS License Manager installation folders.
  2. Create 2 separate services for ArcGIS and FME in LMTools, with unique paths to lmgrd.exe, license file, and debug logs. (NOTE: For reasons still unclear to me, even though LMTools is the Safe Software license manager, you still need a service for ArcGIS, even though license management for ArcGIS is still done primarily through License Administrator. I initially removed the ArcGIS one from LMTools and things stopped working.)
  3. Modify ArcGIS license to use two unique ports to serve licenses on front end and back end.
  4. I had to change the ArcGIS License Manager service to run under a Local System account, because it was stopping as soon as I started it manually.
  5. I changed the ArcGIS license hostname from "this_host" to the actual hostID of the machine; not sure if that was required, but this is how I have it set now and it's working.
  6. Regarding AWS environments, it appears that user IP addresses need to be whitelisted for both the Server and Vendor ports specified in the license files in order to access licenses.
  7. Ensure your users know their IP addresses when they send them to you for whitelisting; one user had specified a local IP address, which I had whitelisted, but he still couldn't access a license. I suspect this may be the main issue, and is certainly a great place to start: verify the address and double check it again to be SURE!

 

I had great support from Safe Software on this, for which I'm very grateful. Hopefully this is useful for anyone else in a similar situation (or me the next time I upgrade the license server...)!

Reply