Solved

FME License server run on LMTools doesn't read option file safe.opt

  • 1 March 2024
  • 3 replies
  • 51 views

Badge +3

Our FME License server run on LMTools by Flexera doesn't read the option file safe.opt.

The safe .log file gives the following log:

xx:xx:xx (safe) CANNOT OPEN options file "="

The safe.opt file is at the same location as the license safe.lic file. Rereading the license file doesn’t seem to work.

I don’t see anywhere else in LMTools where you can configure this. Is their a command line tool with lmutil or lmgrd that adds the option file to the license server config?

 

 

icon

Best answer by jeroen.geo 12 March 2024, 18:00

View original

3 replies

Userlevel 4

Did you perhaps add a reference to the options file on the vendor line in your safe.lic? That should not be necessary as long as the option file is named “safe.opt” and is located next to safe.lic, which I gather is your case. If you did add an  OPTIONS=… part to your safe.lic, try removing it and restarting the license server.

You should see something like the following line in the safe.log:

8:41:51 (safe) Using options file: "C:\Program Files\FlexServer\safe.opt"

Make sure that safe.opt isn’t open in any other programs and that the syntax is correct. Also check the documentation in FlexServer/Documents/LicenseAdministration.pdf on pages 144 and onwards.

Badge +3

Thank you david_r for the response.

The License file has no ‘OPTIONS=…’ part, as all files around it. Adding it like described in the  the documentation in FlexServer/Documents/LicenseAdministration.pdf on pages 144 and onwards also doesn’t help.

 

Badge +3

The license file had an extra space on the VENDOR line, hard to notice, where the option file should be.

‘VENDOR safe  PORT=27001’ → ‘VENDOR safe safe.opt PORT=27001’ or  ‘VENDOR safe PORT=27001’ both work

Reply